Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Mod-rewrite image errors on custom template  (Read 1901 times)

hawkmp

  • Newbie
  • *
  • Karma: 0
  • Posts: 4
Mod-rewrite image errors on custom template
« on: October 02, 2007, 06:17:47 pm »

I just bought a Template Monster template and SNews conforms beautifully to it...at least on the front page.

Every time I try to follow a link (i.e. "contact us"), it sends me to http://domain.com/contact  ... which is correct from what I can tell from an SNews setup

However, none of the images show up because for some reason it is being treated as a completely different web page...the images are being drawn from http://domain.com/contact/images (where none exist) for some reason on that new page...like its treating the rewrite as a new directory...

How do I fix this?
Logged

Joost

  • Guest
Re: Mod-rewrite image errors on custom template
« Reply #1 on: October 02, 2007, 06:43:21 pm »

Welcome to sNews hawkmp,

Your have to insert <?php title(); ?> at the top of index.php between the header tags. This code takes care of:
<title></title>
<base etc.>
<meta etc.>
The html code can be managed in sNews
So you can delete the hardcoded <title>.
Logged

hawkmp

  • Newbie
  • *
  • Karma: 0
  • Posts: 4
Re: Mod-rewrite image errors on custom template
« Reply #2 on: October 02, 2007, 06:53:05 pm »

That was my mistake...upon a brief review of my code, I realized that I have a broken "SHIFT" key...

I put title90;  instead of title();

I appreciate your fast reply...I have to say, this community here is far more helpful than ANY other I have been in...

I have used literally DOZENS of CMS's and have never found one better than this one and the community is far superior as well..

Thank you!
Logged

Joost

  • Guest
Re: Mod-rewrite image errors on custom template
« Reply #3 on: October 02, 2007, 07:12:44 pm »

You're welcome. Thanks for the nice words :)
Logged