Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest sNews - sNews 1.7 - with its own forums - for discussion and user mods.

Author Topic: No links on front page  (Read 3359 times)

Poltoraki

  • Newbie
  • *
  • Karma: 0
  • Posts: 3
No links on front page
« on: November 17, 2006, 05:29:29 am »

Hi!
I have the following problem: when I point browset to: http://localhost/index.php, I can see page with words "sNews", "Categories:", "New comments:", "New Articles:", and "Barbecued by sNews " on bottom of the page. No links and clickable places exept one link to http://snews.solucija.com that is in "Barbecued by sNews "  . If I type: http://localhost/index.php?action=login in browser's address bar, I get the same thing, nothing changes. This is a fresh sNews installation on local XP machine with Apache. I checked Apache config file and rewrite_module is uncommented, so is loading, AllowOverride  is set to All. I don't know what else to check. Any advise?
Thank you in advance!
Logged

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6020
  • Semantically Challenged
    • snews.ca
No links on front page
« Reply #1 on: November 17, 2006, 03:18:55 pm »

Welcome to our sNews Community Poltoraki. In order to help you, we need some basic information.
Questions
1. What server bundle are you using on your local-machine - XAMPP, WAMP, etc.?
2. Where is your site folder located - in XAMPP it would be in the htdocs directory?
3. Do you have the .htaccess file in your site folder?
4. Copy/paste the DATABASE SETTINGS from the top of your snews.php file in here within code tags.
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU

Poltoraki

  • Newbie
  • *
  • Karma: 0
  • Posts: 3
No links on front page
« Reply #2 on: November 18, 2006, 04:30:17 am »

keyrocks, thanks for your reply!
Answers:  :)
1. I didn't use a bundle. I installed Apache (2.0.59) and PHP (5.1.6) separetelly by my self. So far no glitches were noticed, I tested several thinghs on this machine allready with no problem.
2.  All files are in htdocs directory.
3. Yes, .htaccess is in htdocs directory too.
4. snews.php top lines:
// DATABASE VARIABLES
function db($variable) {
   $db = array();
   $db['website'] = 'http://localhost/'; // Path to your sNews installation
   $db['dbhost'] = 'localhost'; //MySQL Host
   $db['dbname'] = 'snews'; //Database Name
   $db['dbuname'] = 'rman'; //Database Username
   $db['dbpass'] = 'rman'; //Database password
   $db['prefix'] = ''; //Database prefix
   $db['dberror'] = 'There was an error while connecting to the database.
 Check your database settings.'; //Database error message
   return $db[$variable];
}
Logged

Fred K

  • Still trying to learn stuff
  • ULTIMATE member
  • ******
  • Karma: 130
  • Posts: 2728
    • Personal
No links on front page
« Reply #3 on: November 18, 2006, 04:42:38 am »

Poltoraki, almost exactly the same thing was asked (and reasonably well sorted out) in this other thread only yesterday. Have a look, I think you'll find it enlightening. http://www.solucija.com/forum/viewtopic.php?id=2254
Logged

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6020
  • Semantically Challenged
    • snews.ca
No links on front page
« Reply #4 on: November 18, 2006, 02:26:56 pm »

Poltoraki - When I create a new sNews web (project) in my htdocs directory, I put all its files and folders within a new folder so I can distinguish between several projects by folder-name. Let's say we are creating our first sNews project. In the htdocs directory, create a folder called snews15rc3 (or whatever you want) and put all files and folders for this site within it. Then... in your snews.php file's Database Settings, use this URL in the website variable string:
Quote
$db['website'] = 'http://localhost/snews15rc3/'; // Path to your sNews installation
And just make sure you keep the forward slash after the site's folder name in the URL.

If you are still having trouble... check the Apache/conf/httpd.conf file to make sure the mod_rewrite string(s) are active.
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU

Poltoraki

  • Newbie
  • *
  • Karma: 0
  • Posts: 3
No links on front page
« Reply #5 on: December 02, 2006, 06:23:30 am »

agentsmith, keyrocks sorry for such a late answer, I've been busy with some other projects and only today could get back to sNews. After several hours of work I didn't manage to get it working on my XP-Apache-MySQL-PHP configuration. Whatever I did, simptoms remained the same: no links on the front page and Apache log shows no errors. I used this config. for quite a bit of time and never had any problems. Altrough it wasn't the best,  I used solution that agentsmith pointed me to: I installed XAMPP, and after mod_rewrite.so was uncommented... I finally got it working :)  Thanks for you help! :)
Logged

philmoz

  • High flyer
  • ULTIMATE member
  • ******
  • Karma: 161
  • Posts: 1988
    • fiddle 'n fly
No links on front page
« Reply #6 on: December 02, 2006, 08:14:43 am »

see snews1.5 bug report

http://www.solucija.com/forum/viewtopic.php?id=2383

oops... disregard ... didn't read things properly :rolleyes:
Logged
Of all the things I have lost, it is my mind that I miss the most.