sNews Forum

Previous sNews versions => sNews 1.5 Final => sNews 1.5 Problem Solving => Topic started by: mikka23 on July 13, 2007, 03:33:32 pm

Title: A couple problems and questions
Post by: mikka23 on July 13, 2007, 03:33:32 pm
Well I think I am getting close to completing the redesign except now I have a couple problems I can't work out.  I currently have comments and read more displayed on the infoline below the article.  That is great and works when you are on category page which displays shortened version of the articles but when I click to go to main article the read more and comments buttons still show. What I want to happen is to have the comments and readmore displayed as they are but in main article I want them to be replaced with social bookmarking buttons.

Anyone have any ideas how to do this?  Sorry for long explanation.  You can see an example of whats happeneing:

http://dating.jamroll.net/ - comments and readmore look great what I want

http://dating.jamroll.net/home/another-tester/ - empty buttons left which I want the social bookmarking to replace.
Title: A couple problems and questions
Post by: mikka23 on July 14, 2007, 04:56:53 pm
I managed to fix both the problems outlined in previous post but have a new problem.  The bookmarking system is not sending the correct URL.  its just sending my homepage with a few backslashes.

Preview is at the bottom of:
http://dating.jamroll.net/home/this-is-a-test/

Any help is appreciated.  I should be able to just send the current page.  Please note the code to display the bookmarking is in the comments function rather that the center function to get it to work.
Title: A couple problems and questions
Post by: philmoz on July 17, 2007, 01:54:58 am
Quote from: mikka23
its just sending my homepage with a few backslashes.
That would indicate that the category and article variables have not been set and/or passed to the output part of the bookmarking script.

Now, assuming you are using Mika's script http://www.solucija.com/forum/viewtopic.php?pid=15805#p15805

Check that variable names are identical within the bookmarking script,
and that the alues mentioned in the function -- bookmark( VALUES IN HERE ) are actually present in in the calling script just above file_include(str_replace('[break]', '', $text), $shorten);