sNews Forum

Previous sNews versions => sNews 1.5 Final => Bug Report => Topic started by: codetwist on February 07, 2007, 06:40:23 pm

Title: new_comments() garbles last character - 1.5.31
Post by: codetwist on February 07, 2007, 06:40:23 pm
When using stock new_comments() function in index.php the last character in output of brief quotation is  garbled if it's language specific character. End of link looks like this -  �...)

No character display problems noticed in other places after applying right fixes :D
Title: new_comments() garbles last character - 1.5.31
Post by: Fred K on February 08, 2007, 06:06:13 am
Valdis - this is exactly the same problem as already reported here (http://www.solucija.com/forum/viewtopic.php?id=3246). That problem has been resolved, see this patch/Fix (http://www.solucija.com/forum/viewtopic.php?pid=22736#p22736)

/* We should use the search function more... ;D */
Title: new_comments() garbles last character - 1.5.31
Post by: piXelatedEmpire on February 08, 2007, 06:16:36 am
Hopefully once 1.5.32 is out and these bugs are squashed we will see these kind of posts drop off and hopefully more mods/addons come to fruition!
Title: new_comments() garbles last character - 1.5.31
Post by: codetwist on February 08, 2007, 09:15:58 am
Quote from: agentsmith
Valdis - this is exactly the same problem as already reported here (http://www.solucija.com/forum/viewtopic.php?id=3246). That problem has been resolved, see this patch/Fix (http://www.solucija.com/forum/viewtopic.php?pid=22736#p22736)

/* We should use the search function more... ;D */
Not sure about this - I mean that I applied changes from 1.5.31 updated on 06.02 (they are same as in that separate post, right?). Thus my comments as such are ok now ... almost. Character is garbled only on screen and only if it's last character of brief quotation. In full view everything is fine as well as the same character in the middle of brief quotation displays ok.

I reckon that this is little different problem :D And I was aware of quoted problem/fix when was reporting this one.
Title: new_comments() garbles last character - 1.5.31
Post by: codetwist on February 08, 2007, 10:20:15 am
I checked into this a little more and feel a little lost.

If I set internal represantion to UTF-8 and use some mbstring functions in new_comments then there is no garbling of last character anymore. May be some settings of environment are wrong? Is mbstring extension needed at all for this to work?