sNews Forum

Previous sNews versions => sNews 1.5 RC and pre-release => sNews 1.5 RC2 version => Topic started by: Jochum Meester on October 16, 2006, 03:12:12 pm

Title: [STICKY] Bug report
Post by: Jochum Meester on October 16, 2006, 03:12:12 pm
OK, let's have all bugs in this topic OK?

- contact form is missing input field for website
Title: [STICKY] Bug report
Post by: Armen on October 16, 2006, 04:59:07 pm
Ok, I've tried the new version out.

Here's what I can say:

1. Contact form is really missing "Website" string. But I think it's okay. If one wants, one can add the string to the code.

2. Script works 10-15% faster now! Good job guys, flies like a rocket.

3. It didn't crash my db, so... Update is'nt dangerous at all.

4. Bad_words.txt didn't work again. Gotta use the fix again
(http://www.solucija.com/forum/viewtopic.php?id=1624).

5. More to come...

BTW!

I'd really appreciate if developers added a button to the "New Article" form that would check if Articles name was unique before posting it.
Title: [STICKY] Bug report
Post by: Mika on October 16, 2006, 04:59:34 pm
- "display new articles on Home" setting cannot be changed (by philmoz)
Title: [STICKY] Bug report
Post by: brauck on October 16, 2006, 09:57:48 pm
Quote from: mika
"display new articles on Home" setting cannot be changed (by philmoz)
and if you change it to 'on' in the db by hand the article won't show if you assign a 'page' as 'homepage'
Title: [STICKY] Bug report
Post by: Jochum Meester on October 17, 2006, 12:59:02 am
- when I try to disable the 'approve-comments' function it doesnt work, when I go back to the settings it is enabled again
- after you remove a comment (I had to approve it first but decided to immediately remove my test-comment by clicking the 'remove' button) the page refreshes with yourdomain.com/home// (double slashes) - has something to do with $link perhaps??
- still some meta's lacking ending slash (at least one in contact form)
Title: [STICKY] Bug report
Post by: Elvino on October 17, 2006, 01:31:12 am
- Contact form is not xhtml 1 strict standards compliance
- Admin Setting not change the website title, Default META Tag description, article limit for page, the approve comments, etc....
Title: [STICKY] Bug report
Post by: AgniZ on October 17, 2006, 04:05:42 pm
well, the messages sent through contact form are not displaying special characters as acute, til ... (or would it be anything that I do need to change?)
AgniZ
Title: [STICKY] Bug report
Post by: Jochum Meester on October 23, 2006, 11:47:24 am
I also noticed that the Site Map doesn't display the categories in the order you set in settings, it displays them by the time they were created, so last created category shows up on the bottom of the site map.
Title: [STICKY] Bug report
Post by: Mika on October 23, 2006, 01:57:59 pm
bugs by Rushi:
---------------------------
Hi All

I am new to this forum. I installed sNews 1.5 RC2.

Few bugs I found out.

1. Thru Admin even if you change home_sef it is not reflecting.
Workaround: change    $l['home'] = 'Books home'; or $l['home_sef'] = 'home';

2. In the function center()

Code: [Select]
if ($r['displaytitle'] == 'YES') {
echo '

';
  if (strlen($txt) > $shorten) {
 echo ''.$r ['title'].''; }
Here you have used variable $txt which should be "$text"
The Bug turns off the link capability of the heading of "Read more" stories.

Will post if found more.

See my implementation at: http://www.hindujagruti.org/books

I am poor at presentation.. if anybody can help in color scheme or suggest about look and feel.. I will be glad.

I am using it as a book publishing tool. It is under construction. I started working over this yesterday....

Title: [STICKY] Bug report
Post by: Jochum Meester on October 23, 2006, 08:08:10 pm
- when you 'forget' the title, your text is being remembered, but written with \n and \r
edit: when I entered the title and submitted, the article didnt show up but WAS added to database...
Title: [STICKY] Bug report
Post by: urbitasmedia on October 24, 2006, 09:00:59 pm
Does anyone know how I can remove "home" from my categories section?  Take a look at the site I'm working on.  It has two "homes" one for the pages and one for the categories.  Thanks.    http://www.toryparish.com
Title: [STICKY] Bug report
Post by: Patric Ahlqvist on October 25, 2006, 07:27:09 am
Ok, now I'm at work and can't bring up snews.php, but do a search in the snews.php and look for

//display categories

In the beginning there should be a line like:

echo '
  • < a href index........>home
  • ';

    Hehe, correct code there, eh ? Note the home link. Just comment it out by adding to slashes in front of it like:

    //echo '
  • < a href index........>home
  • ';

    And you should be off with the categories home link.

    Patric.
    Title: [STICKY] Bug report
    Post by: Luka on October 26, 2006, 04:37:32 pm
    BugFixes:

    - Website URL Field added to the contact form
    - Contact from used to spit wierd characters cause the message string was pulled through a clean function. That's now fixed.
    - Bad words functions fixed
    -  Edit/Approve comment redirect fixed. Now it redirects to the article comment was posted on.
    - Not saving settings bug fixed.
    - When forgetting a title or seftitle, wierd text was entered, that's now fixed. (the same problem as the one on contact form)
    - When forgetting title or seftitle, fieldset open tag was missing, fixed.
    - Breakrow
     tag added to article form.
    - In Sitemap, Articles are now ordered by date and Categories by catorder.
    - Bug reported by rushy ($txt) - fixed.
    - Searching when browsing Contact, Sitemap, Archive, etc. Bug fixed.
    - Readme.html updated as Celebro suggested

    I believe that's it, if you find any more bugs let me know.

    I'll post the final version later today so you could test it.
    Title: [STICKY] Bug report
    Post by: piXelatedEmpire on October 27, 2006, 02:17:08 am
    :D

    great work Luka & co!
    Title: [STICKY] Bug report
    Post by: urbitasmedia on October 27, 2006, 05:52:43 am
    I'm not getting comment approval emails.  Is snews suppose to send me an email if I have comment approval turned "on"?

    The code is rocking.  I love it.
    Title: [STICKY] Bug report
    Post by: klaus on October 27, 2006, 06:07:15 am
    Quote from: Luka
    BugFixes:

    I'll post the final version later today so you could test it.
    Where, where? Thanks. You kick big ass! ;)
    Title: [STICKY] Bug report
    Post by: Patric Ahlqvist on October 27, 2006, 09:00:18 am
    Quote from: urbitasmedia
    I'm not getting comment approval emails.  Is snews suppose to send me an email if I have comment approval turned "on"?

    The code is rocking.  I love it.
    Hi, Urbitasmedia... No snews don't do that. In ver 1.4 you could mod the script to achieve this, but that mod has not been upgraded to work with 1.5. So until then there is no "you've recieved comments" mail send.
    Title: [STICKY] Bug report
    Post by: Luka on October 29, 2006, 09:37:05 pm
    OK, RC3 is almost ready! Before I release it just a quick question:

    Sholud we remove articles from the Sitemap? We're having double content here although on sitemap articles are ordered by categories they belong in and in archive the're sorted by date.
    Title: [STICKY] Bug report
    Post by: Armen on October 29, 2006, 10:05:34 pm
    Quote from: Luka
    OK, RC3 is almost ready! Before I release it just a quick question:

    Sholud we remove articles from the Sitemap? We're having double content here although on sitemap articles are ordered by categories they belong in and in archive the're sorted by date.
    No, please, don't do that. It's better for the search engines. And I, personally, dont much like "Archives" section on any site. Search works for me and if I want to find anything I click "Sitemap" first =)

    Still Luka, you're doing an amazing job. Thank you.
    Title: [STICKY] Bug report
    Post by: Keyrocks on October 29, 2006, 10:49:39 pm
    Thanks for asking Luka. I would have to agree with SerpantiN on this one. :)
    Title: [STICKY] Bug report
    Post by: piXelatedEmpire on October 30, 2006, 05:06:04 am
    Quote from: SerpantiN
    No, please, don't do that. It's better for the search engines. And I, personally, dont much like "Archives" section on any site. Search works for me and if I want to find anything I click "Sitemap" first =)
    Agreed  :cool:
    Title: [STICKY] Bug report
    Post by: bramsyuur on October 30, 2006, 05:43:47 am
    @Luka,
    I agree, too, with SerpantiN, Keyrocks and piXelatedEmpire.
    Thanks mate,
    bram.
    Title: [STICKY] Bug report
    Post by: Andre Griffin on October 30, 2006, 06:00:49 am
    Ditto. Cait wait for RC3!
    Title: [STICKY] Bug report
    Post by: Patric Ahlqvist on October 30, 2006, 11:29:45 am
    Keep sitemap - God.
    Title: [STICKY] Bug report
    Post by: Luka on October 30, 2006, 03:14:23 pm
    OK I'm convinced :) Let me zip it and it's released in no time  :D
    Title: [STICKY] Bug report
    Post by: hafing on October 30, 2006, 04:07:59 pm
    Quote from: Luka
    OK I'm convinced :) Let me zip it and it's released in no time  :D
    Aaahhh. that's a slow Zip tool you are using!
     :cool:

    Look forward to see the new version, Will you list the new changes.
    BTW this is my post nr. 100. so. . .  I am automatically a Hero member. :D
     :cool: