Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest sNews - sNews 1.7 - with its own forums - for discussion and user mods.

Author Topic: Error: requested URL /squizzal/snewsMUlogin/ was not found on this server...???  (Read 5781 times)

dchou

  • Newbie
  • *
  • Karma: 0
  • Posts: 8

I'm new to snews. I've installed it per the instructions and the home page comes up. sNews is installed on my local machine that has both the latest versions or apache, mysql and PHP. But when I click on "login" at the bottom of the page I get the following error:

Not Found
The requested URL /squizzal/snewsMUlogin/ was not found on this server.


I've read over the troubleshoot guide and have modified my httpd.conf file:

<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
</Directory>

If I click on any link other than the home page I get:

Not Found

The requested URL /squizzal/snewsMU***/ was not found on this server.


I'm sure it must be some configuration error. I have the rewrite_mod installed and enabled on my apache server.

Thanks,
Dave


Logged

dchou

  • Newbie
  • *
  • Karma: 0
  • Posts: 8

I finally have the home page displaying correctly with CSS. I moved my "snewsMU" directory up on level and it fixed the display problem. But I still get the error message when I click on "Login". Here is my install structure:

C:\wamp\www\squizzal\snewsMU
   - Under \wamp\www\squizzal
       - There is the snewsMU folder, the following files: .htaccess, index.php, snewsMU.php and style.css
NOTE: The snewsMU folder is currently empty.

The configuration in .htaccess is:

RewriteEngine On
RewriteBase /squizzal/snewsMU/


The configuration in snewsMU.php is:

$db['website'] = 'http://localhost/squizzal/';
$db['dbhost'] = 'localhost'; //MySQL Host
$db['dbname'] = 'snews'; //Database Name

Logged

dchou

  • Newbie
  • *
  • Karma: 0
  • Posts: 8

Just an update...

If  I do a fresh install with the snewsMU folder in the root directory it all works fine. Why is it not possible to put the snewsMU folder in a subdirectory? I'm thinking this may be the way my webserver is configured? Any thoughts?

Thanks,
Dave
Logged

Joost

  • Guest

Just an update...

If  I do a fresh install with the snewsMU folder in the root directory it all works fine. Why is it not possible to put the snewsMU folder in a subdirectory? I'm thinking this may be the way my webserver is configured? Any thoughts?

Thanks,
Dave

It should be possible. Maybe the previous install was slightly different.
Logged

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6019
  • Semantically Challenged
    • snews.ca

Just an update...

Why is it not possible to put the snewsMU folder in a subdirectory? I'm thinking this may be the way my webserver is configured? Any thoughts?

Thanks, Dave

You don't need to put the snewsMU folder (contaiing the sNews file-set) into another folder... you just want to put the file-set into your project folder.

I'm not sure how your localhost bundle is set up... but I use XAMPP for XP... and create all my project folders in the server's root... then put the complete sNews file-set within the project folder and set the URL path in the config settings to that location. As an example... I have a project folder called project21.ca and put all the sNews files in it... then view it with http://localhost/project21.ca/ ... and everything works fine.
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU

dchou

  • Newbie
  • *
  • Karma: 0
  • Posts: 8

Thanks for the replies.

I've found that as long as the folder is in the root directory then everything is ok. If I put it in a folder that is one level down then it won't work correctly. For example if I put the file-set in a folder called "test" which is a subfolder under "snewMU" then when I pull up the link with http://localhost/snewsMU/test snewsMU won't load properly. Seems like it has to be at the root level. I'm thinking it's a configuration thing, but I have no problem putting it in the root level for now.

Thanks,
Dave
Logged

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6019
  • Semantically Challenged
    • snews.ca

Have you tried enabling the #RewriteBase /snewsMU line in the .htaccess file?
If not, then open that file in NotePad... remove the number-sign (which disables it) and add your folder-name to the end of it... so it looks like - RewriteBase /snewsMU/test
This may be required with your sever bundle setup.
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU

dchou

  • Newbie
  • *
  • Karma: 0
  • Posts: 8

Keyrocks,

That was one of the first things I tried, which was listed as a possible solution in the troubleshooting section. However, this edit in the .htaccess file did not do the trick. I'm wondering if anyone has gotten an install at a subfolder to work? If so, it's most likely some setting on my server that is preventing it to work outside of the root folder.

Thanks,
Dave
Logged