Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Author Topic: Install a translation goes wrong  (Read 962 times)

Smith

  • Newbie
  • *
  • Karma: 0
  • Posts: 4
Install a translation goes wrong
« on: December 18, 2007, 11:50:01 pm »

Hello Alll..

Thanks for a great CMS :)

I have downloaded the DA - Danish translation, and made a snews_DA.php file with all the text from this : http://snewscms.com/forum/index.php?topic=5921.0
But when i change under Time & Setting to DA instead of EN , save and reload the page i just get and white empty page.

why is this?
Logged

Joost

  • Guest
Re: Install a translation goes wrong
« Reply #1 on: December 19, 2007, 12:24:57 am »

Welcome Smith,

The code seems al right.
1) Make sure there is no whitespace or newline after ?> at the end of the file.
2) Safe the file as ansi or utf-8 without BOM (byte order mark). These options are provide by any code editor.
Logged

Smith

  • Newbie
  • *
  • Karma: 0
  • Posts: 4
Re: Install a translation goes wrong
« Reply #2 on: December 19, 2007, 01:04:46 am »

Thanks.

Hello Joost.

Well, i god it work now.

i have a linux debian wich runs iso8859-15


in the .htaccess i wrote the line:
AddDefaultCharset iso8859-15

under phpmyadmin my tables are utf-8_generel_ci

ind the code:
snews.php line 1129:
   echo html_input('text', 'charset', 'char', s('charset') == '' ? 'UTF-8' : s('charset'), l('charset'), '', '', '', '', '', '', '', '', '', '');
i changed this to:    echo html_input('text', 'charset', 'char', s('charset') == '' ? 'iso8859-15' : s('charset'), l('charset'), '', '', '', '', '', '', '', '', '', '');

Then under index.php
line 8 <meta http-equiv="Content-Type" content="text/html; charset=iso8859-15" />

Then its works, almost....
The only place were it dont is under hardcoded text.

but then i you the &ae signs..

Any suggestions how to make the last work?
Logged