sNews Forum

sNews 1.7 (current stable version) => Bug reports (1.7) => Topic started by: marengo on March 01, 2013, 10:24:36 PM

Title: Used this script several yrs, now login returns 404
Post by: marengo on March 01, 2013, 10:24:36 PM
Hi,

we used snews several years, everything was fine.
After a server updated by hosting provider admin page cannot be found http://frerealbert.be/admin

What can I do? If something need to be enabled I can do it

PHIPNFO http://frerealbert.be/phpinfo.php
.htaccess:
Code: [Select]
<IfModule mod_php4.c>
    php_value session.use_trans_sid 0
</IfModule>
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
RewriteEngine On
#RewriteBase /snews17
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^(.*) $1 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?category=$1 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z_]+)/([^/]+) index.php?category=$1&title=$2 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z_]+)/([^/]+)/([^/]+)/ index.php?category=$1&title=$2&commentspage=$3 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z0-9_-]+)/([0-9]+)/ index.php?category=$1&nbsp;articlespage=$2 [L]

Thank you
Title: Re: Used this script several yrs, now login returns 404
Post by: Keyrocks on March 02, 2013, 07:03:33 PM
1) No problem with .htaccess file - links to content are working correctly.
2) No problem with database connection -  data being retrieved and displayed correctly.
3) No problem finding the admin login panel (http://frerealbert.be/login/) for your site.

Questions
1) What is the URL in your browser bar after you submit the login form?
2) What do you see in your site's main content container?
3) Do you see a logout link anywhere after logging in and, if so, does it work?
Title: Re: Used this script several yrs, now login returns 404
Post by: Fred K on March 02, 2013, 08:57:06 PM
Quote from: marengo
admin page cannot be found http://frerealbert.be/admin

The url is wrong, in snews 1.7 the admin area "home" url is http://domain.com/administration/ - so the question is why the wrong url? Is it manually constructed? Anyway, if you're using sNews 1.7 the incorrect url would be the reason why the admin page cannot be found.
Title: Re: Used this script several yrs, now login returns 404
Post by: marengo on March 03, 2013, 12:22:43 AM
Quote
No problem finding the admin login panel for your site.

Oh, yes, thank you, I tried a wrong URL so  :o
http://frerealbert.be/login/ works just fine

Sorry for the confusion and thank you for the help

Regards,
Nathalie