Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Author Topic: System Requirements  (Read 3504 times)

bionicman

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 51
System Requirements
« on: April 17, 2006, 12:44:43 PM »

Which version of PHP/MySQL needs sNews? And what host addons?
Logged

hafing

  • Full Member
  • ***
  • Karma: 1
  • Posts: 174
System Requirements
« Reply #1 on: April 17, 2006, 07:24:59 PM »

Good question! ;D

It would be great to gather in one place all the relevant information concerning what is needed to install sNews.  
List:
·Host requirements

· Host addons! 

· Database requirements and version

· Programming language requirements and version

· etc



hafing 8)
Logged
I can be 2fast and 2curious

bramsyuur

  • Hero Member
  • *****
  • Karma: 23
  • Posts: 873
    • http://snews.vietbee.net
System Requirements
« Reply #2 on: April 17, 2006, 07:44:50 PM »

I don't know what's the minimal requirements to run snews in a server, but here, I post my server specs/config
only for information:

- My server:
CentOS 4.2 (Open Source distro server based in the free code of Red Hat Enterprise Linux)
Linux Kernel 2.6.9-22.0.2.ELsmp
Apache 2.0.52 with mod_rewrite (for SefURL's and for other things)
PHP 4.3.9 compiled as a CGI (normal compiled work too) with Zend Engine (without, it work too)
MySQL 4.1.12 with (optional) PhpMyAdmin (for managing databases with web panel manager)
Other things installed but not relevant to make working sNews (any versions of it).

This server are serving local and external pages to my friends and clients (with multiple virtual domains in apache).

This is all, I hope this helps to get idea of what kind of server specs do you need (of couse, a lot of differents
servers/systems configs are working too).
bram.
Logged
La comunidad sNews en tu idioma!
Comunidad sNews en Espaņol