Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Author Topic: Stylesheet not loading  (Read 3698 times)

mrjiles

  • Newbie
  • *
  • Karma: 1
  • Posts: 9
Stylesheet not loading
« on: September 12, 2008, 05:46:56 PM »

Hi everybody, this is my first post!

Anyway, I have sNews running great.  Only problem is, the stylesheet is not loading with the MU version.  The regular version loads the stylesheet fine but when I upgraded to MU is when it stopped working.  I even started a fresh sNews MU install but have the same problem.  This is with the original stylesheet and template.

Any ideas?
Logged

Joost

  • Guest
Re: Stylesheet not loading
« Reply #1 on: September 12, 2008, 05:59:49 PM »

Welcome mrjiles, :)

It means the browser can not locate the stylesheet. Did you set $db['website'] correctly?
the address looks like: http;//web.site.com/ Don't forget the trailing slash.
Logged

mrjiles

  • Newbie
  • *
  • Karma: 1
  • Posts: 9
Re: Stylesheet not loading
« Reply #2 on: September 12, 2008, 06:10:16 PM »

Yes, it's set correctly.  In the template (index.php) I even changed the address of the stylesheet so it's not relative (ie: changed from "style.css" to "http://localhost/sNews16/style.css" and still nothing).

Edit:  Doesn't make any sense!  I haven't dug into the code but does sNews parse the stylesheet tag by chance?
« Last Edit: September 12, 2008, 06:12:18 PM by mrjiles »
Logged

Joost

  • Guest
Re: Stylesheet not loading
« Reply #3 on: September 12, 2008, 06:17:53 PM »

Yes, it's set correctly.  In the template (index.php) I even changed the address of the stylesheet so it's not relative (ie: changed from "style.css" to "http://localhost/sNews16/style.css" and still nothing).

Edit:  Doesn't make any sense!  I haven't dug into the code but does sNews parse the stylesheet tag by chance?
Indeed it doesn't make sense. Everything hardcoded (strings written outside <?php ?>) is not handled by php.
Logged

mrjiles

  • Newbie
  • *
  • Karma: 1
  • Posts: 9
Re: Stylesheet not loading
« Reply #4 on: September 12, 2008, 06:20:32 PM »

Ok, pointed to one of Ebay's stylesheets and it's including that fine.  Must be something with Abyss webserver.  I'll just include the stylesheet in with index.php for now.

Edit:  It's a problem with Firefox in some way.  IE is loading the stylesheet fine.
« Last Edit: September 12, 2008, 06:24:40 PM by mrjiles »
Logged

Silver Knight

  • Newbie
  • *
  • Karma: 0
  • Posts: 19
Re: Stylesheet not loading
« Reply #5 on: February 09, 2009, 04:57:50 AM »

i have the same problem....
Logged