Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Author Topic: 404 Error and .htaccess help  (Read 3426 times)

fuelmedia

  • Newbie
  • *
  • Karma: 0
  • Posts: 4
    • Fuel Media Central
404 Error and .htaccess help
« on: April 27, 2008, 08:13:03 AM »

I am trying to get my site up and running at my temp home http://s006.panelboxmanager.com/~myfuelm/snewsMU/ when I click on all of the links I get Not Found

The requested URL /snewsMU/index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Please Help Me! PS I am New to the CMS and sNews world I am using sNewsMU.
Logged

jlhaslip

  • Sr. Member
  • ****
  • Karma: 16
  • Posts: 374
    • My snews with AEF Forum site
Re: 404 Error and .htaccess help
« Reply #1 on: April 27, 2008, 03:17:34 PM »

Post a copy of your .htaccess file here, please. Looks like there could be an issue in there.
Did you adjust the .htaccess file by uncommenting and adjusting the location of the files?
Do you know if an .htaccess file is allowed for your your hosting account?
Logged
Yes! I have no siggy.

fuelmedia

  • Newbie
  • *
  • Karma: 0
  • Posts: 4
    • Fuel Media Central
Re: 404 Error and .htaccess help
« Reply #2 on: April 29, 2008, 04:11:00 AM »

<IfModule mod_php4.c>
    php_value session.use_trans_sid 0
</IfModule>
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
RewriteEngine On
RewriteBase /snewsMU
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^(.*) $1 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?category=$1 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z_]+)/([^/]+) index.php?category=$1&title=$2 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z_]+)/([^/]+)/([^/]+)/ index.php?category=$1&title=$2&commentspage=$3 [L]
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z0-9_-]+)/([0-9]+)/ index.php?category=$1&nbsp;articlespage=$2 [L]
« Last Edit: April 29, 2008, 04:21:33 AM by fuelmedia »
Logged

Patric Ahlqvist

  • Nobodys perfect, but Im pretty effing close
  • ULTIMATE member
  • ******
  • Karma: 65
  • Posts: 4867
  • I'm a self-made man and worships my creator.
    • p-ahlqvist.com
Re: 404 Error and .htaccess help
« Reply #3 on: April 29, 2008, 10:30:08 AM »

I myself have the RewriteBase /snewsMU commented out, so it looks like this:

#RewriteBase /snewsMU

Could you also post your settings from snews.php here ? De-personilized of course (that is without username - password).
And the  latter question from haslip is somewhat important... Make sure .htaccess is allowed on your host, and furthermore... Is mod_rewrite enabled on the server ?

Can you please make a new empty file called eg: info.php and paste this into it:
Quote from:  the incredable Pman
<?php phpinfo(); ?>

Upload it to server and post link to it here.
Logged
My sNews site
"It's only dead fish that goes with the flow... "
Updated, online again - Free designs

DataVoyager

  • Newbie
  • *
  • Karma: 0
  • Posts: 6
Re: 404 Error and .htaccess help
« Reply #4 on: September 26, 2008, 02:58:09 AM »

Hi Folks,

Not sure if this will be helpful but I had a few similar problems and found the answers on the help pages here.

The key was in the httpd.conf file which required the following modifications:

Change:

Directory />
  Options FollowSymLinks
  AllowOverride None
</Directory>


to:

<Directory />
  Options FollowSymLinks
  AllowOverride All
</Directory>


You then have to make sure that your htdocs or root folder is correctly referenced

<Directory /var/www/html/mysite.com/snews_directory/>
  Options FollowSymLinks
  AllowOverride All
</Directory>


I got confused by the httpd file because the above was separated by lots of comments.

The full text of my httpd file actually reads:

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "C:/Program Files/Apache Group/Apache2/htdocs">

#
# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important.  Please see
# http://httpd.apache.org/docs/2.0/mod/core.html#options
# for more information.
#
    Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
    AllowOverride ALL

#
# Controls who can get stuff from this server.
#
    Order allow,deny
    Allow from all

</Directory>


Hope this helps,
DV
Logged