Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Author Topic: SQL gurus help urgent!  (Read 4119 times)

adamos

  • Newbie
  • *
  • Karma: 0
  • Posts: 43
SQL gurus help urgent!
« on: December 20, 2007, 09:41:11 PM »

Hello,

I did my snews website on my laptop using XAMPP. [PHP5 (5.2.5), MySQL (5.0.51), phpMyAdmin (2.11.3)]

The issue is that i have to upload the database on MySQL 3.23.55 on solaris 8(i didnt know that from first place) and it doesnt work! i cant even use collate utf8_unicode_ci or upload my dumped .sql file in the database.

Any solutions for that? i was thinking to upgrade to mysql 5 but i read everywhere that you have to go version-by-version and solaris face many issues. i am really frustrated with this issue. i have 8 more databases on the current sql server and i dont want to risk it. is any way to implement my current database to mysql 3.23?

Thanks,

Adam
Logged

codetwist

  • Hero Member
  • *****
  • Karma: 50
  • Posts: 940
Re: SQL gurus help urgent!
« Reply #1 on: December 20, 2007, 10:09:03 PM »

Just an ideas as migration is pain always ;)
1) What for do You need utf-8? I mean site You talked about earlier looks plain English in other words its ole ASCII, no utf-8 even needed. May be try to change to some simpler encoding at Your development database (BACKUP FIRST) as I don't think there is anything like solid utf-8 even in some v.4.0.* of MySQL.
2) Check if all SQL datatypes used at sNews are available at MySQL v.3.
Logged

adamos

  • Newbie
  • *
  • Karma: 0
  • Posts: 43
Re: SQL gurus help urgent!
« Reply #2 on: December 20, 2007, 11:54:15 PM »

i used utf-8 unicode case insensitive because i had trouble with the search query.

what char set do you suggest for MySQL 3.23.55?

worst scenario is to start from scratch! do the initial sNews tables and redo the pages.
Logged

codetwist

  • Hero Member
  • *****
  • Karma: 50
  • Posts: 940
Re: SQL gurus help urgent!
« Reply #3 on: December 21, 2007, 12:25:38 PM »

For starters You may found out what settings are used by those 8 databases already on v.3.* . Might be with charset settings that are available at v.5 as well. Really, I don't know for sure; some latin1 or win1251 - but these are pure guesses. Haven't worked much with v.3.* . May by You can get better qualified help on this at MySQL own site/forum.
Logged