Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2] 3 4

Author Topic: [Mod]Integrating ZenPhoto in sNews 1.6 WIP  (Read 25285 times)

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #15 on: August 24, 2007, 09:38:52 PM »

It is supposed to add you ZenPhoto gallery recent pictures and random images (didn't you say you were having trouble?!?) in your sNews template (not only in the zen themes).


I was looking to do something similar sometime ago.  I found the following treat in the zenphoto forum, but the members there are not as friendly and nice as you guys… so I didn't accomplish anything :(.  Hope you guys can!

http://www.zenphoto.org/support/topic.php?id=7&page=2

This will help you accomplish what you wanted to achieve with Random Images showing on you snews site
« Last Edit: August 25, 2007, 12:46:16 AM by centered effect »
Logged

Zucye

  • Sr. Member
  • ****
  • Karma: 5
  • Posts: 347
    • Simplemente una Mujer
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #16 on: August 25, 2007, 02:44:05 PM »

Yes I did.  I just wanted to be sure :D

I will give it a try on Monday. 

Happy weekend!!!!
Logged
We can always learn from our failures, not so much from obvious success - C. Robinson (W. Disney). :)

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #17 on: August 25, 2007, 05:39:46 PM »

Probably Monday or so I will try and incorperate the snews login with Zenphoto, so you can just log into snews and when you click on gallery admin, you are logged into zenphoto.

Based on this code:
http://www.zenphoto.org/support/topic.php?id=755#post-4165
and
http://www.zenphoto.org/support/topic.php?id=40

Unless Baker beats me to it!

EDIT... harder than I expected it to be....

I will also try out the RSS mod for zenphoto as well: http://www.zenphoto.org/support/topic.php?id=764
« Last Edit: August 26, 2007, 05:46:01 AM by centered effect »
Logged

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #18 on: August 26, 2007, 06:24:26 PM »

Ok I have RSS working for the full gallery and albums.  I have to test for multiple gallerys.  The login seems to be beyond my scope of copy and pasting,  some more logic is involved to make this work.
Logged

Zucye

  • Sr. Member
  • ****
  • Karma: 5
  • Posts: 347
    • Simplemente una Mujer
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #19 on: August 27, 2007, 06:58:24 PM »

It works nicely! Thanks a lot!

But now some of the pages show the following message :( : Zenphoto error: Album does not exist.

I will check to see if I did something wrong later

** I just realized is not only the pages, but the articles as well.  Shame it looked so nice  :(
« Last Edit: August 27, 2007, 07:00:38 PM by Zucye »
Logged
We can always learn from our failures, not so much from obvious success - C. Robinson (W. Disney). :)

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #20 on: August 27, 2007, 07:23:01 PM »

Are you using the downloaded package?
Logged

Zucye

  • Sr. Member
  • ****
  • Karma: 5
  • Posts: 347
    • Simplemente una Mujer
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #21 on: August 27, 2007, 10:17:30 PM »

No! I didn't use the download package.  Because my snews file is modded.

==========================
(A while Later)

Ok, I tried again, same result the random image appears, the lastes pictures as well, but if I click a page or an article I get the message: Zenphoto error: Album does not exist.

I follow you instruction from Step 3 to 10  very carefully, with the following exceptions:
When ever you have snews.php'); ?>, I used snews-split.php'); ?> (I use the subpages MOD)

Therefore my Step #3 was like this:
Code: [Select]
<?php session_start(); include('snews-split.php'); define('WEBPATH''zenphoto'); require_once("zenphoto/zen/template-functions.php"); ?>I assumed I had to change "gallery" with the name of my folder.


Also I added the Step #9 right after:
Code: [Select]
  // Send the mail
UTF8::send_mail("Admin <" . zp_conf('admin_email') . ">", $subject, $message, $headers);
  }
}
since you didn't specied exactly where to add it.

What did I do wrong??

==========================
(Another while Later)

I think I might have gotten this issue confused.  Because If I think about it, it should work correctly if it is used in the zenphoto template pages, but I am trying to use it in the main index.php.  That didn’t sound very clear.  This is what I'm trying to say I wan to see the images in http://www.zucye.net/, which does work, but does not let me see the articles, categories or pages when clicked.  But If I put it in another page it work correctly for example http://www.zucye.net/indexgalery.php.

Should I be able to see it in my main index.php or not? Or is this Mod only for the zenphoto template page??
« Last Edit: August 28, 2007, 12:03:02 AM by Zucye »
Logged
We can always learn from our failures, not so much from obvious success - C. Robinson (W. Disney). :)

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #22 on: August 28, 2007, 12:41:58 AM »

hmm pretty odd since it should work...

Step 3 is correct, changing the folder name to reflect your own folder.

Step 9 I added it at the end before the closing ?>

This mod is for the zenphoto and snews indexes so all pages will reflect the recent galleries and other functions you may want to be shown on all pages. 

To note, I do not have htacess enabled for zenphoto on my localhost, I do not know if that may be an issue...

The idea I may have is the php functions may not be processing correctly somehow.  Evidence shows this:
==== Testing begings =====
New images:

Random image:
".$randomImage->getTitle().""; ?>
==== Testing ends =====
on your page: http://www.zucye.net/portada/galeria/

My sNews index looks like this:
Code: [Select]
<?php session_start(); include('snews.php'); define('WEBPATH''gallery'); require_once("gallery/zen/template-functions.php"); ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<?php title(); ?>
<meta name="Robots" content="index,follow" />
<meta name="Generator" content="sNews 1.6" />
<link rel="stylesheet" type="text/css" href="style.css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="rss-articles/" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="rss-pages/" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="rss-comments/" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="gallery/rss.php" />
</head>
<body>
<div class="wrap">
<div id="logo">
<h1><?php echo s('website_title'); ?></h1>
</div>
<ul id="menu">
<?php pages(); ?>
</ul>
<div id="subheader">
<div id="breadcrumbs">
<?php breadcrumbs(); ?>
</div>
<div id="search">
<?php searchform(); ?>
</div>
</div>
<div id="left">
<h3>Categories:</h3>
<ul>
<?php categories(); ?>
</ul>
<h3>New Articles:</h3>
<ul>
<?php menu_articles(0,3); ?>
</ul>
<h3>New comments:</h3>
<ul>
<?php new_comments(530); ?>
</ul>
<h3>New images:</h3>
<ul>
<?php show_latest_images(4); ?>
<ul>
<h3>Random image:</h3>
<?php $randomImage getRandomImages(); $randomImageURL getURL($randomImage); print "<a href='".getURL($randomImage)."' title='Random Picture...'><img src='".$randomImage->getCustomImage(85620180620180300300)."' alt='".$randomImage->getTitle()."' /></a>"?>
<?php extra(); ?>
</div>
<div id="right">
<?php center(); ?>
</div>
<div id="footer">
<ul id="rss">
<?php rss_links(); ?>
<li><a href="gallery/rss.php">RSS Gallery</a></li>
</ul>
<p>Barbecued by <a href="http://snews.solucija.com/" title="Single file CMS">sNews</a> &middot; <?php login_link(); ?></p>
</div>
</div>
</body>
</html>



EDIT*  Can anyone else let me know if this is working for them??
« Last Edit: August 28, 2007, 01:32:52 AM by centered effect »
Logged

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #23 on: August 29, 2007, 11:48:38 PM »

Added reflections to the recent images function in the first post
Logged

Zucye

  • Sr. Member
  • ****
  • Karma: 5
  • Posts: 347
    • Simplemente una Mujer
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #24 on: September 04, 2007, 05:34:16 PM »

It works! :D   I am sorry for all the confusion… Actually I don’t know what went wrong, but after reinstalling zenphoto (perhaps it was not compatible with the older version), it worked perfectly.

I and not using it with my index page (but I tested it), because I have to make some adjustments first, but is in use in my gallery and I just love the way it looks.  Thanks Centered!

Btw:  I have notice for sometime now that when I share the same date base (snews and zenphoto) I get the following error message in my admin panel:
Quote
MySQL Query ( SELECT c.id, i.title, i.filename, a.folder, a.title AS albumtitle, c.name, c.website, c.date, c.comment FROM `comments` AS c, `images` AS i, `albums` AS a WHERE c.imageid = i.id AND i.albumid = a.id ORDER BY c.id DESC LIMIT 10 ) Failed. Error: Unknown column 'c.website' in 'field list'
How did you overcome that??

Not that it is a big deal, but I am curious :)
Logged
We can always learn from our failures, not so much from obvious success - C. Robinson (W. Disney). :)

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #25 on: September 05, 2007, 01:45:42 PM »

Awesome Zucye!  I don't get that error at all in my test version and my database has the snews database with zen using a prefix.  Might be something to do with the comments table.  Is the comments working at all? 
Logged

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6019
  • Semantically Challenged
    • snews.ca
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #26 on: September 05, 2007, 05:39:19 PM »

It's been a while since I used ZenPhoto with sNews and I will be doing it soon in a new project. If it is any help... I do remember, tho, that the last time I used it I prefixed all of the ZenPhoto database tables with zp_ to eliminate possible conflicts, and the prefixed tables worked OK located in the same database as the sNews tables.
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #27 on: September 05, 2007, 06:19:39 PM »

Right Keys.

Zucye it seems maybe Zen comments needs the prefix to function correctly.  View my defualt 1.6 install with Zen
Logged

centered

  • Guest
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #28 on: September 05, 2007, 06:56:01 PM »

If anyone wants to try the RSS for Zen then here it is:
http://www.bosnervos.de/rss-for-gallery-and-albums.zip

Doesn't work exactly as I hoped but it does work for the most part
Logged

Boogada

  • Newbie
  • *
  • Karma: 3
  • Posts: 27
Re: [Mod]Integrating ZenPhoto in sNews 1.6 WIP
« Reply #29 on: September 08, 2007, 11:59:40 AM »

Hi,

first off I'm a newbie to both snews and zenphoto, but I thought I give it a try. I probably forgot something or whatever but I got into these problems. when I go to the site I do not get the images displayed properly. the sidebar is not really working for the recent images etc..

now if I go to the gallery it works! I see the random image etc.. but the design is broken.

how to fix this?

link to my site
link to gallery
Logged
Pages: 1 [2] 3 4