Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Pages: 1 2 [3] 4 5

Author Topic: sNews1.4-txtdb  (Read 37701 times)

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #30 on: March 08, 2006, 04:59:01 PM »

will try that.

thanks very much for all your help dobey!

We SHALL overcome!!!  ;)

tim0fee
Logged

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #31 on: March 08, 2006, 05:51:50 PM »

dobey,

...Just continuing this thread for anybody who might be having similar problems:

I phoned my server techies and they said that the three .txt flat files are owned by the 'webserver' and so cannot be modified or deleted by me! Odd. So a workaround I've tried is to simply create the db folder manually and 777 it BEFORE uploading it. Then the .txt files created on the fly hold their true 777 permissions and can be modified by me. Phew.

BUT I have still the problem of vanishing articles/future posting malarkey. I have narrowed it down to attaching IMAGES. Whenever I attach an image to an article - when I log back in - Vamoosh! the article has vanished (actually it has gone into unpublished state) !!!  ???

So I'm afraid this ticket is still open to anyone who might know what is wrong ??? Any takers ?

thanks to all

tim0fee
Logged

Rod

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 78
    • http://www.rjs-custom.com
sNews1.4-txtdb
« Reply #32 on: March 08, 2006, 06:39:49 PM »

If the files are owned by user 'webserver', then running the scipt that I posted above should allow them to be removed, since it is being run by the  'webserver' user.

As for the images/future posting thing, I am looking into it and see what I can come up with.
Logged
Whatever went wrong, I am pretty sure I didn't do it!  Well atleast I think I didn't do it...

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #33 on: March 08, 2006, 07:02:59 PM »

hey dobey,

thanks that wud be great! Unfortunately it wudn't even let me upload that script u posted !!! lol

cheers dood.

tim0fee
Logged

Rod

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 78
    • http://www.rjs-custom.com
sNews1.4-txtdb
« Reply #34 on: March 08, 2006, 07:05:45 PM »

then try changing it to this, and upload it to the main snews folder

Code: [Select]

function s($variable) {
$s = Array();

// Database prefix
$s['prefix'] = "";

return $s[$variable];
}

// remove articles
@unlink("./inc/dbs/".s('prefix')."articles.txt");

// remove categories
@unlink("./inc/dbs/".s('prefix')."categories.txt");

// remove comments
@unlink("./inc/dbs/".s('prefix')."comments.txt");

?>
Logged
Whatever went wrong, I am pretty sure I didn't do it!  Well atleast I think I didn't do it...

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #35 on: March 08, 2006, 07:16:01 PM »

ooops! I get this now;

Parse error: parse error, unexpected T_STRING in /home/fhlinux205/s/*****.co.uk/user/htdocs/sNews14-txtdb/remove.php on line 3

??

tim0fee
Logged

Rod

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 78
    • http://www.rjs-custom.com
sNews1.4-txtdb
« Reply #36 on: March 08, 2006, 07:29:48 PM »

try this instead

Code: [Select]

// remove articles
@unlink("./inc/dbs/articles.txt");

// remove categories
@unlink("./inc/dbs/categories.txt");

// remove comments
@unlink("./inc/dbs/comments.txt");

?>
Logged
Whatever went wrong, I am pretty sure I didn't do it!  Well atleast I think I didn't do it...

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #37 on: March 08, 2006, 07:37:19 PM »

hahaha!

That nuked the f**kers!

Brilliant.

dobey rocks!

Thankx!

tim0fee
Logged

Rod

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 78
    • http://www.rjs-custom.com
sNews1.4-txtdb
« Reply #38 on: March 08, 2006, 07:52:11 PM »

no prob, now if I can remember to link to this script whenever anyone else has this problem, hehe.

As for the other stuff concerning images/future postings.  Does this happen with the mysql version as well or just the txtdb version.

Find out from your webhost what is allowed for mod_rewrite, ie:

Code: [Select]
Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews

as this will help solve the other issues that you are having, knowing what you can execute/do within the webserver may resolve this issue, and if you do not want to post it here (security issues), pm me and I'll send you my email address, so we can try to fix this as soon as possible.
Logged
Whatever went wrong, I am pretty sure I didn't do it!  Well atleast I think I didn't do it...

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #39 on: March 08, 2006, 08:12:29 PM »

dobey thanks

is this any good to you ? If not I can PM you with my phpinfo.php link...

Loaded Modules:

mod_php4, mod_frontpage, mod_setenvif, mod_so, mod_headers, mod_expires, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_status, mod_negotiation, mod_mime, mod_log_referer, mod_log_agent, mod_log_config, mod_env, mod_bandwidth, mod_matrix_vhost, http_core

And no this business with vanishing articles/images doesen't happen with the MySQL version!  ???


tim0fee
Logged

Rod

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 78
    • http://www.rjs-custom.com
sNews1.4-txtdb
« Reply #40 on: March 08, 2006, 08:17:58 PM »

everything seems to be there.

yeah please pm me the phpinfo link, I wanna check something that is a little hard to explain, but I know it when I see it.  It concerns flatfiles and the way they are handled by PHP.
Logged
Whatever went wrong, I am pretty sure I didn't do it!  Well atleast I think I didn't do it...

Rod

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 78
    • http://www.rjs-custom.com
sNews1.4-txtdb
« Reply #41 on: March 08, 2006, 08:41:03 PM »

checked the file you sent and it is all there.

Also posted an article, and created a new category.  Added a picture and removed the picture, and it still seems to function properly for me????
Logged
Whatever went wrong, I am pretty sure I didn't do it!  Well atleast I think I didn't do it...

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #42 on: March 08, 2006, 08:42:24 PM »

k let me play a second...I'm sure I can break it!!! lol

Logged

tim0fee

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 71
sNews1.4-txtdb
« Reply #43 on: March 08, 2006, 08:46:18 PM »

Now try it! I logged back in and removed the image from your article...Now try clicking on the dobey link and the article has vanished!!

 ???
Logged

Rod

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 78
    • http://www.rjs-custom.com
sNews1.4-txtdb
« Reply #44 on: March 08, 2006, 08:52:04 PM »

yup, it is gone.  But when I do it all works.  Weird.

you got a gmail accout?
Logged
Whatever went wrong, I am pretty sure I didn't do it!  Well atleast I think I didn't do it...
Pages: 1 2 [3] 4 5