Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Pages: 1 2 [3] 4 5 6

Author Topic: sNews 1.4 RC1 (Release Candidate 1)  (Read 47899 times)

George Antoniadis

  • Sr. Member
  • ****
  • Karma: 0
  • Posts: 479
sNews 1.4 RC1 (Release Candidate 1)
« Reply #30 on: February 11, 2006, 08:02:39 AM »

thanx bryn and JM... ^_^

bryn about the apostrofe thing... apostrofes are not very well accepted url characters...
many apache versions and/or configurations get messy with characters like that...
so it's best practice to remove them from SEF urls...

if you are worried about search engines not understanding them,, don't...
in most dont and don't is the same... (don`t also...) and stuff like that...

about the rest you guys said I'll check them today and get back to you! ^_^
Logged
How I feel like I'm starless, I'm ready to fade now.
And how I feel like I'm starless, I'm hopeless and greyed out.

bryn

  • Hero Member
  • *****
  • Karma: 2
  • Posts: 934
    • http://www.cssugly.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #31 on: February 11, 2006, 09:38:36 AM »

that's true 'a'..I mentioned it merely in case there was a solution, and as a reference in case anybody else came across the same thing..I agree with you totally from an SEO point of view, but the question arises as to whether it is grammatically correct..it does also strip out the question mark if my title were a question for example ;)

no biggie though..

I personally don't need the javascript SEF function as I would prefer to manually edit both titles anyway to add more/different keywords..but an option to turn this off altogether would be handier I think ;D
Logged
Over 1,000 posts of joy, sNews is not only brilliant, but fun too! thanks guys :D

albert

  • Sr. Member
  • ****
  • Karma: 0
  • Posts: 405
    • http://www.oswt.co.uk/
sNews 1.4 RC1 (Release Candidate 1)
« Reply #32 on: February 11, 2006, 09:54:49 AM »

Hi Bryn

I had the same thing wth adding a new cat, I dd not thnk it was a bug !!

I thght you had to add txt to that cat 1st page then add pages after that. "silly me!!!"

Albert

Logged
Albert
http://snews.awddesign.co.uk/snews/ site: v1.3
http://snews.awddesign.co.uk/           site: v1.2 http://www.awddesign.co.uk/
“Putting together the largest collection of sNews 1.5 designs. Coming very soon :)

bryn

  • Hero Member
  • *****
  • Karma: 2
  • Posts: 934
    • http://www.cssugly.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #33 on: February 11, 2006, 10:01:51 AM »

Hi Albert..sorry I was modifying my post above..yes it does the same for new Cats too..it's not really a problem as it displays on the page correctly ;D
Logged
Over 1,000 posts of joy, sNews is not only brilliant, but fun too! thanks guys :D

bryn

  • Hero Member
  • *****
  • Karma: 2
  • Posts: 934
    • http://www.cssugly.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #34 on: February 11, 2006, 10:50:08 AM »

another possible bug..

Go to archives page => select article => hit back button => should return to archives and not the home page?
Logged
Over 1,000 posts of joy, sNews is not only brilliant, but fun too! thanks guys :D

Jochum Meester

  • Sr. Member
  • ****
  • Karma: 1
  • Posts: 309
    • JochumMeester.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #35 on: February 11, 2006, 11:14:29 AM »

Perhaps it could be changed into javascript:history.goback(-1)  ??
(is that the correct script to go back? i'm not the js expert here hehe)
Logged

bryn

  • Hero Member
  • *****
  • Karma: 2
  • Posts: 934
    • http://www.cssugly.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #36 on: February 11, 2006, 11:27:01 AM »

it could use the javascript history yes..but I wonder if there is a way to do this better with the php code? :)
Logged
Over 1,000 posts of joy, sNews is not only brilliant, but fun too! thanks guys :D

Patric Ahlqvist

  • Nobodys perfect, but Im pretty effing close
  • ULTIMATE member
  • ******
  • Karma: 65
  • Posts: 4867
  • “I'm a self-made man and worships my creator.”
    • p-ahlqvist.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #37 on: February 11, 2006, 11:51:22 AM »

JM - it should be "javascript:history.go (-1)". Not "goback" the back thingy you take care of by the - character...

Brynnie - Don't steal all my bugreporting's ;)

P
Logged
"It's only dead fish that goes with the flow... "
Updated

George Antoniadis

  • Sr. Member
  • ****
  • Karma: 0
  • Posts: 479
sNews 1.4 RC1 (Release Candidate 1)
« Reply #38 on: February 11, 2006, 12:32:40 PM »

about the history no javascript history suxxx big time...
back thingie cannot the done another other way because it doesn't go just back... back would be the posting/editing form...

it could be a session variable with referrer history but really no reason for it...
Logged
How I feel like I'm starless, I'm ready to fade now.
And how I feel like I'm starless, I'm hopeless and greyed out.

bryn

  • Hero Member
  • *****
  • Karma: 2
  • Posts: 934
    • http://www.cssugly.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #39 on: February 11, 2006, 02:07:25 PM »

sorry being a bit dumb this morning 'a'..[trying to do ten things at once as usual]..so are you saying that this can't be done, and every time you want to view an article from the archives..you have to return to the home page first..if so thats not good  :-

might have to consider hardcoding a link next to it then maybe?

@ Patric: sorry mate..great minds think alike as they say ;D
Logged
Over 1,000 posts of joy, sNews is not only brilliant, but fun too! thanks guys :D

Patric Ahlqvist

  • Nobodys perfect, but Im pretty effing close
  • ULTIMATE member
  • ******
  • Karma: 65
  • Posts: 4867
  • “I'm a self-made man and worships my creator.”
    • p-ahlqvist.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #40 on: February 11, 2006, 07:40:42 PM »

@bryn ;)...just kidding.

@everybody - RSS feed. Ok So I must be dumb...Hear me out. The rss.xml should be generated when pressing the link for the first time, eh ? So why don' it at my page ? I haven't changed anything vital in the snews.php...just some minor img tags and p tags nothing else...The rss limit is as it was. havn't touched anything else, but I can't get the damn thing to work...And you prolly will tell me that your's do, right ? ;)...RSS = Radical Suck Sucking, as far as I'm concerned right now...I will chew the RSS feature up and spit it out my arse....*somewhat irritated*

Ok, so I'm a bit more calm now...Could someone please help me, I'll post my RSS feed function here aswell as the links to it and the header tags:

Code: [Select]
Headertag:


Footer link:
RSS Feed

sNews.php RSS settings:
$s['rss_limit'] = "5"; // Limit RSS feed to a number of articles
$s['rss_date_format'] = "l dS of F Y h:i:s A"; // RSS date format (DATE_RFC822)

sNews.php //RSS feed:
// RSS FEED
function rss() {
$limit = s('rss_limit');
$query = "SELECT * FROM articles WHERE position = 1 ORDER BY date DESC LIMIT 0, $limit";
$result = mysql_query($query);
$filename = "rss.xml";
$header = "";
$header .= "";
$header .= "";
$header .= "" .s('website_title'). "";
$header .= "" .s('website_title'). "";
$header .= "" .s('website'). "";
$header .= "Copyright " .s('website_title'). "";
$footer = "
";
$footer .= "
";
$fh = fopen($filename, "w+");
fwrite($fh, $header);
while ($r = mysql_fetch_assoc($result)){
$date = date(s('rss_date_format'), strtotime($r['date']));
    $pattern="'<[/!]*?[^<>]*?>'si";
    $replace="";
    $description = preg_replace($pattern, $replace, stripslashes($r['text']));
    $item  ="";
    $item .= "". $r['title'] ."";
    $item .= "". $description ."";
    $item .= "". $date ."";
    $item .= "". s(website) . find_cat_sef($r['category']). "/" .$r['seftitle']. "/";
    $item .= "
";
    fwrite($fh, $item);
  }
fwrite($fh, $footer);
fclose($fh);
echo "";
}




Page : http://p-ahlqvist.com/sNews/patric_6/

Phu' leeeeeeeeeeeeeeease ;)
Logged
"It's only dead fish that goes with the flow... "
Updated

Jochum Meester

  • Sr. Member
  • ****
  • Karma: 1
  • Posts: 309
    • JochumMeester.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #41 on: February 11, 2006, 08:38:43 PM »

Doesn't work for me either, only thing I haven't tried is chmodding the root map to 777 (which sounds not right to me btw) but I've just added my own empty rss.xml file.
Logged

Patric Ahlqvist

  • Nobodys perfect, but Im pretty effing close
  • ULTIMATE member
  • ******
  • Karma: 65
  • Posts: 4867
  • “I'm a self-made man and worships my creator.”
    • p-ahlqvist.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #42 on: February 11, 2006, 08:42:18 PM »

Yea, I've added an empty one aswell...didn't work, I get redirected to my 404 page. I have also deleted the rss.xml in order for sNews to "make" a new one...I have copied from another folder and changed the URL's and stuff, but I can not get it to work...

AAAAAAAANAL? D'you'rs work ;)
Logged
"It's only dead fish that goes with the flow... "
Updated

Patric Ahlqvist

  • Nobodys perfect, but Im pretty effing close
  • ULTIMATE member
  • ******
  • Karma: 65
  • Posts: 4867
  • “I'm a self-made man and worships my creator.”
    • p-ahlqvist.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #43 on: February 11, 2006, 08:55:00 PM »

Oh, I might add that I haven't found anything else (other than stated by me and others) so far in my spanking of the script ;)...

Seems almost...knock on wood...done soon :)

Having a cupla beers tonight, Luka ? You're well worth it, pal. Have one for me and say hello to the croatian ladies for me, will you, hehe...Raurrrgh, wink, wink ;)
Logged
"It's only dead fish that goes with the flow... "
Updated

bryn

  • Hero Member
  • *****
  • Karma: 2
  • Posts: 934
    • http://www.cssugly.com
sNews 1.4 RC1 (Release Candidate 1)
« Reply #44 on: February 11, 2006, 09:13:11 PM »

just to let you guys know..I'm also having problems..it worked at first, I changed a few small things but nothing that should have affected the rss..deleted the xml and had it create a new one..installed a new one myself..etc etc.

hardcoding the rss/ link didnt do the trick, and the only way I got anything to show was to add the full path to rss.xml..but it's quirky..I gave up for a while to concentrate on other things

me think that maybe it's to do with the .htaccess file somewheres..no other problems other than those I've already reported ;D
Logged
Over 1,000 posts of joy, sNews is not only brilliant, but fun too! thanks guys :D
Pages: 1 2 [3] 4 5 6