Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2] 3

Author Topic: You are not currently logged in and so are not allowed to do that  (Read 30980 times)

bramsyuur

  • Hero Member
  • *****
  • Karma: 23
  • Posts: 873
    • http://snews.vietbee.net
You are not currently logged in and so are not allowed to do that
« Reply #15 on: March 29, 2007, 11:03:16 PM »

Quote from: janpd24
Well, I just installed sNews 1.5.31, and I'm having the same wrong username/password error. I've been trying with test/test, but it's not working  :( . I've given my db tables a prefix of snews, but surely it can't be anything to do with that?

I wonder if the order I did things might be the problem. I ran the MySQL code to create the tables first and then uploaded the files. Would that matter?  :|
Have you looked at "Announcement" field of this forum? http://www.solucija.com/forum/viewtopic.php?pid=22719#p22719
Logged
La comunidad sNews en tu idioma!
Comunidad sNews en Español

Janpd24

  • Newbie
  • *
  • Karma: 0
  • Posts: 28
    • http://writeside.net/
You are not currently logged in and so are not allowed to do that
« Reply #16 on: March 30, 2007, 12:57:32 AM »

Quote from: bramsyuur
Have you looked at "Announcement" field of this forum? http://www.solucija.com/forum/viewtopic.php?pid=22719#p22719
Yep  :) Only posted after that didn't do the trick.
Logged
"People assume that time is a simple progression of cause to effect, but actually, from a non-linear, non-subjective viewpoint, it's more of a big ball of... wibbly-wobbly... timey-wimey... stuff."

Fred K

  • Still trying to learn stuff
  • ULTIMATE member
  • ******
  • Karma: 130
  • Posts: 2728
    • Personal
You are not currently logged in and so are not allowed to do that
« Reply #17 on: March 30, 2007, 02:00:50 AM »

Quote from: janpd24
I wonder if the order I did things might be the problem. I ran the MySQL code to create the tables first and then uploaded the files. Would that matter?
Order doesn't matter, unless you try to access your site _before_ creating the database... but you didn't so no worries. Actually it's probably best to create the database first, then muck about with the php files, but as long as all the info is correct by the time you try accessing your page, it should just work. Normally. So I think we're going to need some more info. Are you working with an online version or locally? What kind of server are you set up on? Have you used a WYSIWYG editor somewhere in the process (Dreamweaver, MS Frontpage and a couple of others are known to add extra code by default, which could screw things up)? Are all the necessary files in the right place and correctly configured? Do you have a url to the site if it's online?
[turning blue in the face, pauses to catch breath]
Logged

Janpd24

  • Newbie
  • *
  • Karma: 0
  • Posts: 28
    • http://writeside.net/
You are not currently logged in and so are not allowed to do that
« Reply #18 on: March 30, 2007, 10:27:20 AM »

Easy, Agentsmith! :) To answer all your questions:

Are you working with an online version or locally?
- Online. http://snews.writeside.net/

What kind of server are you set up on?
- Apache 1.3.37 (Unix); PHP 5.2.1; MySQL 4.1.21-standard... (am I missing anything?)

Have you used a WYSIWYG editor somewhere in the process (Dreamweaver, MS Frontpage and a couple of others are known to add extra code by default, which could screw things up)?
- Nope! Never use any of that. I always hand code. I'm using Notepad++ in fact.

 Are all the necessary files in the right place and correctly configured?
- Ooh,I hope so! I followed the readme instructions.

Do you have a url to the site if it's online?
- http://snews.writeside.net. I should be able to log in using test/test, but cannot :(

EDIT: Looking at my tables through PHPMyadmin, I find the tables have been created as 'Articles', 'Categories', 'Comments' and 'Settings', that is, WITHOUT the prefix I assigned! Is that the problem?

EDIT 2: Sorry for editing again... but I removed the prefix in the snews.php file and now I can log in! Everything's working now, but I'd rather have tables with a prefix (as I'm using one database for a lot of things)!
Logged
"People assume that time is a simple progression of cause to effect, but actually, from a non-linear, non-subjective viewpoint, it's more of a big ball of... wibbly-wobbly... timey-wimey... stuff."

Patric Ahlqvist

  • Nobodys perfect, but Im pretty effing close
  • ULTIMATE member
  • ******
  • Karma: 65
  • Posts: 4867
  • “I'm a self-made man and worships my creator.”
    • p-ahlqvist.com
You are not currently logged in and so are not allowed to do that
« Reply #19 on: March 30, 2007, 11:53:12 AM »

You should really change that test/test to something else...

Delete the current snews data base then and run this (change PREFIX for your own)
Quote
CREATE TABLE PREFIX_articles (
   id int(11) primary key auto_increment,
   title varchar(100) default NULL,
   seftitle varchar(100) default NULL,
     `text` longtext,
     `date` datetime default NULL,
     category int(8) NOT NULL default '0',
     position int(6) default NULL,
     displaytitle char(3) NOT NULL default 'YES',
     displayinfo char(3) NOT NULL default 'YES',
     commentable varchar(5) NOT NULL default '',
     published int(3) NOT NULL default '1',
     description_meta varchar(255) default NULL,
     keywords_meta varchar(255) default NULL
);

CREATE TABLE PREFIX_categories (
     id int(8) primary key auto_increment,
    name varchar(100) NOT NULL,
    seftitle varchar(100) NOT NULL,
    description varchar(255) NOT NULL,
    published varchar(4) NOT NULL default 'YES',
    catorder smallint(6) NOT NULL default '0'
);

CREATE TABLE PREFIX_comments (
    id int(11) primary key auto_increment,
    articleid int(11) default '0',
    name varchar(50),
    url varchar(100) NOT NULL,
    comment text,
    time datetime NOT NULL default '0000-00-00 00:00:00',
    approved varchar(5) NOT NULL default 'True'
);

CREATE TABLE PREFIX_settings (
    id int(8) primary key auto_increment,
    name varchar(20) NOT NULL,
    `value` varchar(60) NOT NULL
);

   INSERT INTO PREFIX_settings VALUES (1, 'website_title', 'sNews 1.5');
   INSERT INTO PREFIX_settings VALUES (2, 'home_sef', 'home');
   INSERT INTO PREFIX_settings VALUES (3, 'website_description', 'sNews CMS');
   INSERT INTO PREFIX_settings VALUES (4, 'website_keywords', 'new, site, snews');
   INSERT INTO PREFIX_settings VALUES (5, 'website_email', 'info@mydomain.com');
   INSERT INTO PREFIX_settings VALUES (6, 'contact_subject', 'Contact Form');
   INSERT INTO PREFIX_settings VALUES (7, 'language', 'EN');
   INSERT INTO PREFIX_settings VALUES (8, 'charset', 'UTF-8');
   INSERT INTO PREFIX_settings VALUES (9, 'date_format', 'd.m.Y. H:i');
   INSERT INTO PREFIX_settings VALUES (10, 'article_limit', '3');
   INSERT INTO PREFIX_settings VALUES (11, 'rss_limit', '5');
   INSERT INTO PREFIX_settings VALUES (12, 'display_page', '');
   INSERT INTO PREFIX_settings VALUES (13, 'display_new_on_home', '');
   INSERT INTO PREFIX_settings VALUES (14, 'display_pagination', '');
   INSERT INTO PREFIX_settings VALUES (15, 'num_categories', 'on');
   INSERT INTO PREFIX_settings VALUES (16, 'approve_comments', '');
   INSERT INTO PREFIX_settings VALUES (17, 'comments_order', 'ASC');
   INSERT INTO PREFIX_settings VALUES (18, 'comment_limit', '30');
   INSERT INTO PREFIX_settings VALUES (19, 'word_filter_enable', '');
   INSERT INTO PREFIX_settings VALUES (20, 'word_filter_file', '');
   INSERT INTO PREFIX_settings VALUES (21, 'word_filter_change', '');
   INSERT INTO PREFIX_settings VALUES (22, 'username', 'test');
   INSERT INTO PREFIX_settings VALUES (23, 'password', '098f6bcd4621d373cade4e832627b4f6');
Logged
"It's only dead fish that goes with the flow... "
Updated

Fred K

  • Still trying to learn stuff
  • ULTIMATE member
  • ******
  • Karma: 130
  • Posts: 2728
    • Personal
You are not currently logged in and so are not allowed to do that
« Reply #20 on: March 30, 2007, 02:10:25 PM »

Listen to Patric, janne*
whenever you set a prefix in the website variable, in snews.php, that same prefix must also be put into the db as Patric shows.
And once you're in the Admin panel, change your user/pass, quick as you can.

---
*) "Janne" is the Swedish nickname for anyone named Jan... ;)
Logged

Janpd24

  • Newbie
  • *
  • Karma: 0
  • Posts: 28
    • http://writeside.net/
You are not currently logged in and so are not allowed to do that
« Reply #21 on: March 30, 2007, 04:19:20 PM »

Tack* to both Patric and Agentsmith!  :P

All sorted, and I think I'm going to use sNews for a new client project I'm about to take up! Thanks again.


=================
* My knowledge of Swedish is limited to that, a few greetings, and some swear words!  :cool:
Logged
"People assume that time is a simple progression of cause to effect, but actually, from a non-linear, non-subjective viewpoint, it's more of a big ball of... wibbly-wobbly... timey-wimey... stuff."

winchester

  • Newbie
  • *
  • Karma: 0
  • Posts: 3
You are not currently logged in and so are not allowed to do that
« Reply #22 on: May 04, 2007, 06:25:41 PM »

Hi, I'm having this very same problem.

Quote
Error

You are not currently logged in and so are not allowed to do that.
I'm using a fresh installation of version 1.5.31. (testing it before going live).

Here's the URL for my test site: http://demo.axjamaica.com/snews

You can try to log in to see what I'm talking about.

Does anyone have any idea how to work this out? I'd really appreciate it.
Logged

Janpd24

  • Newbie
  • *
  • Karma: 0
  • Posts: 28
    • http://writeside.net/
You are not currently logged in and so are not allowed to do that
« Reply #23 on: May 04, 2007, 11:27:08 PM »

winchester, my problem was solved after I figured that the table prefix I had set in my snews.php file and the tables I had created with the given code didn't match. Are you sure you have the right settings?
Logged
"People assume that time is a simple progression of cause to effect, but actually, from a non-linear, non-subjective viewpoint, it's more of a big ball of... wibbly-wobbly... timey-wimey... stuff."

Joost

  • Guest
You are not currently logged in and so are not allowed to do that
« Reply #24 on: May 05, 2007, 07:16:57 AM »

@winchester,
Are you sure you have sNews version  1.5.31 installed? It looks as though you have installed 1.5.30 ?
It has got nothing to do with any installation problems, but for security reasons, you have to install the latest version, 1.5.31.
Logged

siraxi

  • Guest
You are not currently logged in and so are not allowed to do that
« Reply #25 on: May 05, 2007, 10:59:41 PM »

Well, this sucks. Just installed the CMS and it already needs modifications in order to be able to log in... How advanced is this CMS anyway?
Logged

Fred K

  • Still trying to learn stuff
  • ULTIMATE member
  • ******
  • Karma: 130
  • Posts: 2728
    • Personal
You are not currently logged in and so are not allowed to do that
« Reply #26 on: May 06, 2007, 12:44:15 AM »

Well that's a nice way of saying hello. Sorry to hear you're having troubles, but seriously, lip won't get you much help.

That said, there is info to be had. Have you read this thread for starters? Funny, it's got exactly the same headline as this one, you'd think it might contain some answers to your unforunate predicament ... right?

Read the thread, if that doesn't help you then try the link that says Error messages at the top of this and every other page. And if that still doesn't help, then come back and try to explain in more detail your setup and what's going wrong. You can bark at me to, if you feel like it, that's ok. ;)
Logged

Joost

  • Guest
You are not currently logged in and so are not allowed to do that
« Reply #27 on: May 06, 2007, 01:42:04 AM »

Quote from: siraxi
Well, this sucks. Just installed the CMS and it already needs modifications in order to be able to log in... How advanced is this CMS anyway?
There is no need for modifications  to log in if sNews when it is located in the root directory.
If, for instance, sNews is located in  directory 'folder' you have to edit .htaccess.
Uncomment the following line in .htaccess and change 'sNews15' to 'folder' (no trailing forward slash).
Code: [Select]
#RewriteBase /sNews15It will have to look like this:
Code: [Select]
#RewriteBase /folderThere are some minor bugfixes that should be added to your fresh install. 1.5.31 was a released quick to solve some security issues, so some bugs were shipped with the release.   The next version will solve this, I expect.

The idea is to keep sNews simple and flexible for developers, designers and modders. However, most basic features are already present. Out of the box, it can be used as a website or weblog.
You can find a lot of small mods, some big mods, addons and free template designs here. With little effort, your site won't have to look like a typical sNews site.

From experience I can tell that you can find very adequate help here.

ps: If you know a small cms, that can be installed on any Apache server without the need of tweaking the system, let me know :)
Logged

Arthur Cundy

  • Newbie
  • *
  • Karma: 0
  • Posts: 9
    • http://www.3elevencreative.com
You are not currently logged in and so are not allowed to do that
« Reply #28 on: May 06, 2007, 02:13:30 AM »

Quote from: dziegiel
I cant login:
"Wrong username and/or password."
I created table 'settings' with above code.
I'm afraid I've got the same issue.

www.cafe-list.com
Logged

winchester

  • Newbie
  • *
  • Karma: 0
  • Posts: 3
You are not currently logged in and so are not allowed to do that
« Reply #29 on: May 06, 2007, 04:14:50 AM »

It seems it was 1.5.30.

I originally installed the one with the DesignCriativo Template without realizing it was not  v1.5.31.

I changed the snews.php file and it works fine now. Thanks everyone. :)
Logged
Pages: 1 [2] 3