Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2 3 ... 10

Author Topic: sNews 1.4 - General Bugs and Comments  (Read 63249 times)

bryn

  • Hero Member
  • *****
  • Karma: 2
  • Posts: 934
    • http://www.cssugly.com
sNews 1.4 - General Bugs and Comments
« on: January 28, 2006, 12:04:19 AM »

Starting a new thread for the latest release of 1.4Beta from Luka..please post your general bugs, comments, and thank you's here..cheers ;D
Logged
Over 1,000 posts of joy, sNews is not only brilliant, but fun too! thanks guys :D

Mario

  • Newbie
  • *
  • Karma: 0
  • Posts: 43
sNews 1.4 - General Bugs and Comments
« Reply #1 on: January 28, 2006, 12:20:27 AM »

Editing the position of the article from center to left or right changes the status of the article to: unpublished. Anyone else tried this yet?
Logged

Jochum Meester

  • Sr. Member
  • ****
  • Karma: 1
  • Posts: 309
    • JochumMeester.com
sNews 1.4 - General Bugs and Comments
« Reply #2 on: January 28, 2006, 12:52:38 AM »

1) Editing in general causes this, I think. EDIT: it sets a future date so it seems... when I try to change it into a past date it does nothing.
2) My menu items won't display when I'm not logged in, or is there simply nothing to show?
3) The RSS takes data from the whole database, instead of the snews tables (with prefixes) or is this normal?
4) Try this: add an article to Home and pick 'right'. It disappears... not only does it not show up on the page (simply because there is no 'right' section) but it's also gone from the RSS, so probably also from the database?
5) Where is the Archive section?

Perhaps for later:
4) Comment form: your name can't be 2 characters (like mine: JM)?
5) Logout error takes you straight back to login form, perhaps a little error message?


www.iseeyou-designs.com/projects/snewstest/


Thanks Luka, good work. And thanks everyone else for their help.
Logged

Rehuel Lobato de Mesquita

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 61
sNews 1.4 - General Bugs and Comments
« Reply #3 on: January 28, 2006, 12:58:59 AM »

Is it me or is this release "Windows-unfriendly"?

Im working on making it Windows-Compatible
Logged
Stretsh Out...

Procrastination is like masturbation. You do it till you figure out you're only screwing yourself!

George Antoniadis

  • Sr. Member
  • ****
  • Karma: 0
  • Posts: 479
sNews 1.4 - General Bugs and Comments
« Reply #4 on: January 28, 2006, 05:37:56 AM »

"Windows-unfriendly"? say what? :P
you mean on a windows server? :P

if you get the htaccess to work in windows then you should be fine! ^_^
Logged
How I feel like I'm starless, I'm ready to fade now.
And how I feel like I'm starless, I'm hopeless and greyed out.

ketut

  • Full Member
  • ***
  • Karma: 0
  • Posts: 115
    • Book Bali Hotels
sNews 1.4 - General Bugs and Comments
« Reply #5 on: January 28, 2006, 06:09:00 AM »

sNews work fine both of normal url and SEF url. I use Apache Web Server Version 1.3.34 on my Windows XP.
I use AppServ Version 2.4.5 for Windows bundle with Apache and MySQL. It's wonderfull freeware web server, that mod_rewrite (.htaccess) work well on my computer, previuosly all of my free webserver software did not work at all.
This free software can be download at : http://www.appservnetwork.com/
Thanks! ;D 8)

albert

  • Sr. Member
  • ****
  • Karma: 0
  • Posts: 405
    • http://www.oswt.co.uk/
sNews 1.4 - General Bugs and Comments
« Reply #6 on: January 28, 2006, 06:47:09 AM »

Hi JM

ref v1.4

Quote
Perhaps for later:
4) Comment form: your name can't be 2 characters (like mine: JM)?

Look for // COMMENTS in the code and find this about 10 lines down.

Code: [Select]
if ($commentspage == 0) { $commentspage = 1; }
if (isset($_POST['comment']) AND strlen($_POST['name']) > 2 AND strlen($_POST['comment']) > 5) {

so you would change the  > 2 to >1 to add JM (name)

comment > 5 caracters and more

Albert
Logged
Albert
http://snews.awddesign.co.uk/snews/ site: v1.3
http://snews.awddesign.co.uk/           site: v1.2 http://www.awddesign.co.uk/
“Putting together the largest collection of sNews 1.5 designs. Coming very soon :)

Tom Gebauer

  • Newbie
  • *
  • Karma: 0
  • Posts: 11
sNews 1.4 - General Bugs and Comments
« Reply #7 on: January 28, 2006, 07:44:07 AM »

OK guys, this is my first time posting here, so "Hello" from New Jersey, US.

I've installed the sNews 1.4 beta on both my localhost server and my web server:
Link:  http://www.t0mg.com/sNewsTest/

I seem to get the same error on both when I try to log in - it is looking for a directory that doesn't exist (the "login" directory).  Have I configured something wrong, or are others having this problem?  Let me know - it's late over here, time to get to bed.

sNews 1.4... time to celebrate!

Logged

George Antoniadis

  • Sr. Member
  • ****
  • Karma: 0
  • Posts: 479
sNews 1.4 - General Bugs and Comments
« Reply #8 on: January 28, 2006, 02:00:18 PM »

Just a question...
how will 1.3 users upgrade to 1.4? o_O
Since I don't think there is a way without SEFURLS should there be a "converter" that would try to get the title, strip out special characters, replace spaces with underscores and the update the SQL? :///

Or is there a very simple way I don't see? :///
Logged
How I feel like I'm starless, I'm ready to fade now.
And how I feel like I'm starless, I'm hopeless and greyed out.

George Antoniadis

  • Sr. Member
  • ****
  • Karma: 0
  • Posts: 479
sNews 1.4 - General Bugs and Comments
« Reply #9 on: January 28, 2006, 02:08:31 PM »

Classic bug on posting articles when tables are prefixed:
search for:
Code: [Select]
$query = "INSERT INTO ". s('prefix'). " articles(title,seftitle,text,textlimit,date,category,position,displaytitle,displayinfo,commentable,image,published) VALUES('". $title ."', '". $seftitle ."', '". $text ."', '". $text_limit ."', '". $date ."', '". $category ."', '". $position ."', '". $display_title ."', '". $display_info ."', '". $commentable ."', '". $image ."', '". $fpublished ."')";it's around line 1314...
and replace with:
Code: [Select]
$query = "INSERT INTO ". s('prefix'). "articles(title,seftitle,text,textlimit,date,category,position,displaytitle,displayinfo,commentable,image,published) VALUES('". $title ."', '". $seftitle ."', '". $text ."', '". $text_limit ."', '". $date ."', '". $category ."', '". $position ."', '". $display_title ."', '". $display_info ."', '". $commentable ."', '". $image ."', '". $fpublished ."')";
Logged
How I feel like I'm starless, I'm ready to fade now.
And how I feel like I'm starless, I'm hopeless and greyed out.

Rehuel Lobato de Mesquita

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 61
sNews 1.4 - General Bugs and Comments
« Reply #10 on: January 28, 2006, 07:48:23 PM »

I have appserv 2.4.2 installed on my Win2K system.

This bug by analyzerx was my problem. Now it all works fine on my local machine
Logged
Stretsh Out...

Procrastination is like masturbation. You do it till you figure out you're only screwing yourself!

Patric Ahlqvist

  • Nobodys perfect, but Im pretty effing close
  • ULTIMATE member
  • ******
  • Karma: 65
  • Posts: 4867
  • “I'm a self-made man and worships my creator.”
    • p-ahlqvist.com
sNews 1.4 - General Bugs and Comments
« Reply #11 on: January 28, 2006, 08:29:24 PM »

So it does ;).

I was wondering one thign though... I have the same tables as in patric_8 going here, but I see no menu items... I have not tampered with anything at all, but the postingbug. The menu items however, such as home- archive- contact are not to be found...

EDIT--> oh, and possibly a small thing...When logging in one is taken to a: "You are Logged In Logout" message... not to "home" where one could start editing articles. One have to click the home link first... As I said, not a but thing, but still ;)
EDIT 2 --> Never mind, I took this outta the older test version:
Code: [Select]
echo "
  • " .l('home'). "
  • ";
    echo "
  • " .l('archives'). "
  • ";

    And inserted in the blank space here:
    Code: [Select]
    echo "
    Logged
    "It's only dead fish that goes with the flow... "
    Updated

    albert

    • Sr. Member
    • ****
    • Karma: 0
    • Posts: 405
      • http://www.oswt.co.uk/
    sNews 1.4 - General Bugs and Comments
    « Reply #12 on: January 30, 2006, 02:04:32 PM »

    Hi Luka and All

    try this.

    Add an artcal but do not add sef link  and see what Happen with snews 1.4 beta ?

    Albert
    Logged
    Albert
    http://snews.awddesign.co.uk/snews/ site: v1.3
    http://snews.awddesign.co.uk/           site: v1.2 http://www.awddesign.co.uk/
    “Putting together the largest collection of sNews 1.5 designs. Coming very soon :)

    Mario

    • Newbie
    • *
    • Karma: 0
    • Posts: 43
    sNews 1.4 - General Bugs and Comments
    « Reply #13 on: January 30, 2006, 02:19:49 PM »

    Quote from: albert
    Hi Luka and All

    try this.

    Add an artcal but do not add sef link  and see what Happen with snews 1.4 beta ?

    Albert


    I get:

    "Error

    Either a title or SEF title was not entered

    Back"

    That's suppose to happen, isn't it?
    Logged

    Patric Ahlqvist

    • Nobodys perfect, but Im pretty effing close
    • ULTIMATE member
    • ******
    • Karma: 65
    • Posts: 4867
    • “I'm a self-made man and worships my creator.”
      • p-ahlqvist.com
    sNews 1.4 - General Bugs and Comments
    « Reply #14 on: January 30, 2006, 03:06:24 PM »

    Me to, Mario, and I think that's supposed to happen ;). What happens to you, abe ?
    Logged
    "It's only dead fish that goes with the flow... "
    Updated
    Pages: [1] 2 3 ... 10