Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest sNews - sNews 1.7 - with its own forums - for discussion and user mods.

Pages: 1 [2] 3 4

Author Topic: Bug report  (Read 25208 times)

markuz

  • Newbie
  • *
  • Karma: 0
  • Posts: 22
Bug report
« Reply #15 on: December 02, 2006, 11:53:27 AM »

These strings doesn't show up anywhere:
$l['article_date'] = 'Article date (enter a higher date for future posting)';
$l['a_approve'] = 'Approve';
Logged

markuz

  • Newbie
  • *
  • Karma: 0
  • Posts: 22
Bug report
« Reply #16 on: December 02, 2006, 12:16:16 PM »

This should be at the "#settings form" -block (few lines downwards)
173: $l['contents'] = 'Contents;

This should be at the "#customize article" -block (few lines upwards)
135 :$l['enable'] = 'Enable';

These should be at the "#settings form" -block"
105: $l['login_status'] = 'Login status';
111: $l['logout'] = 'Logout';
148: $l['files'] = 'Files';

Okay. There are lots of other strings also, that are not mayby where they should be. That depends of course how do you look at things. But for a translator it would be a good thing to find all the strings, that belong together, from the same block.
Logged

Mika

  • Hero Member
  • *****
  • Karma: 9
  • Posts: 1377
    • http://www.ni5ni6.com/
Bug report
« Reply #17 on: December 02, 2006, 12:59:08 PM »

- future posting time format
- missing article date string
fix:
Quote
function form_articles() {
...
...
if ($contents == 'article_new' || $edit_option == 1) {
      html_input('fieldset', '', '', '', '', '', '', '', '', '', '', '', '', '', ''.l('publish_date').'');
      echo '';
   }
}
comment approval doesn't work
fix
Quote
function edit_comment() {
   echo '

'.l('edit_comment').'

';
   $commentid = $_GET['commentid'];
   $query = mysql_query("SELECT * FROM ".db('prefix')."comments WHERE id='$commentid'");
   $r = mysql_fetch_array($query);
   html_input('form', '', 'post', '', '', '', '', '', '', '', '', '', 'post', 'index.php?action=process&task=editcomment&id='.$commentid, '');
...
- hardcoded "Login" string
fix:
Quote
function login() {
   if ($_SESSION[db('website').'Logged_In'] != 'True') {
      echo '

'.l('login').'

';
...
-strings doesn't show up
fix
Quote
/*delete or comment out this line from language variables*/
$l['a_approve'] = 'Approve';
Thanks for finding those, guys&gals :)
Logged
http://www.ni5ni6.com/ - Tutorials, Mods and How-To's about sNews CMS
sNews 1.6 Developers Edition - commented sNews 1.6 version

markuz

  • Newbie
  • *
  • Karma: 0
  • Posts: 22
Bug report
« Reply #18 on: December 02, 2006, 01:26:20 PM »

Missing a period before the 'html'
217: $l['file_include_extensions'] = '.php,.txt,.inc,.htm,html';
Logged

markuz

  • Newbie
  • *
  • Karma: 0
  • Posts: 22
Bug report
« Reply #19 on: December 02, 2006, 01:34:40 PM »

Function filelist() (line 1537) is not obeying the forbidden extension html, because of this substr-function:
line 1542: in_array(substr($file, -3), $extension)
Logged

Mika

  • Hero Member
  • *****
  • Karma: 9
  • Posts: 1377
    • http://www.ni5ni6.com/
Bug report
« Reply #20 on: December 02, 2006, 01:47:59 PM »

- missing a period in $l['file_include_extensions']
don't change! see this thread: http://www.solucija.com/forum/viewtopic.php?pid=12901#p12901

- function filelist
fix:
Quote
// FILELIST FUNCTION
function filelist($mode, $path, $depth = 0) {
   $ignore = array('cgi-bin', '.htaccess', '.', '..', 'Thumbs.db');
# period added before php
   $extension = array('.php', 'html');
   $dh = @opendir($path);
   while (false !== ($file = readdir($dh))) {
# size of the elements in array changed to 4
      if(!in_array($file, $ignore) && !in_array(substr($file, -4), $extension)) {
...
Logged
http://www.ni5ni6.com/ - Tutorials, Mods and How-To's about sNews CMS
sNews 1.6 Developers Edition - commented sNews 1.6 version

Harold

  • Full Member
  • ***
  • Karma: 0
  • Posts: 110
    • http://blog.haroldbeukers.nl/
Bug report
« Reply #21 on: December 02, 2006, 01:56:05 PM »

the same as snews 1.5 RC3: message #12:Contact form and comment form is not xhtml 1 strict standards compliance
 and message #21:by writing an article: when i use a single quote - ' like this' - ,the text won't  appear after submitting.

bug report snews 1.5 RC3
Logged
E=Fb

markuz

  • Newbie
  • *
  • Karma: 0
  • Posts: 22
Bug report
« Reply #22 on: December 02, 2006, 02:08:16 PM »

Quote from: Mika
- missing a period in $l['file_include_extensions']
don't change! see this thread: http://www.solucija.com/forum/viewtopic.php?pid=12901#p12901
Oh, sorry. Of course. I didn't look at the function. :(
Logged

Mika

  • Hero Member
  • *****
  • Karma: 9
  • Posts: 1377
    • http://www.ni5ni6.com/
Bug report
« Reply #23 on: December 02, 2006, 03:27:27 PM »

harold, try this and tell us did it fixed your problem

- single quote issue
fix (comments):
Quote
function comment($freeze_status) {
...
if (isset($_POST['comment'])) {
   $comment = cleanXSS($_POST['text']);
   if(!get_magic_quotes_gpc()) {$comment = addslashes($comment);}
...
fix (text):
Quote
function processing() {
...
$text = $_POST['text'];
if(!get_magic_quotes_gpc()) {$text = addslashes($text);}
...
NOTE: you should run (put this line inside an empty some-name.php file, upload to your server and run it) to check whether magic_quotes_xxx is ON or OFF

my server example:
magic_quotes_gpc   On   On
magic_quotes_runtime   Off   Off
magic_quotes_sybase   Off   Off
Logged
http://www.ni5ni6.com/ - Tutorials, Mods and How-To's about sNews CMS
sNews 1.6 Developers Edition - commented sNews 1.6 version

Mika

  • Hero Member
  • *****
  • Karma: 9
  • Posts: 1377
    • http://www.ni5ni6.com/
Bug report
« Reply #24 on: December 02, 2006, 03:29:30 PM »

and regarding comments and contact area code validity, feel free to use elvino's solution ;)
Logged
http://www.ni5ni6.com/ - Tutorials, Mods and How-To's about sNews CMS
sNews 1.6 Developers Edition - commented sNews 1.6 version

celebro

  • Guest
Bug report
« Reply #25 on: December 02, 2006, 03:31:56 PM »

RC1 -> Stable w/ Designcreativo template.

Deleting an article only removed it from from the admin panel it did not remove the links to it on the site or the entry from the database,... It was an article that was unpublished.
Logged

Mika

  • Hero Member
  • *****
  • Karma: 9
  • Posts: 1377
    • http://www.ni5ni6.com/
Bug report
« Reply #26 on: December 02, 2006, 03:39:02 PM »

?? what version exactly?

I just deleted an article in my test site and it disappeared completely from my db..(as supposed)

edit: vitor's template and regular stable versions are the same
Logged
http://www.ni5ni6.com/ - Tutorials, Mods and How-To's about sNews CMS
sNews 1.6 Developers Edition - commented sNews 1.6 version

celebro

  • Guest
Bug report
« Reply #27 on: December 02, 2006, 03:45:05 PM »

Originaly the database I had was a 1.5-RC1(shouldn't matter I think) database, but I stopped using it until stable came out,... now I went to try out the 1.5-stable w/ vitors template... there was an unpublished article I had created previously and went into the admin panel to delete it, I noticed it got removed from the admin -> articles  section, but since I had created a link to this article (kinda like a hidden page - Thank You Page to be exact) I noticed I was still able to view the article.

I fired up phpmyadmin and noticed the article was still in the database it was just not showing in the admin section.
Logged

Harold

  • Full Member
  • ***
  • Karma: 0
  • Posts: 110
    • http://blog.haroldbeukers.nl/
Bug report
« Reply #28 on: December 02, 2006, 05:56:26 PM »

Quote from: Mika
harold, try this and tell us did it fixed your problem

- single quote issue
fix (comments):
Quote
function comment($freeze_status) {
...
if (isset($_POST['comment'])) {
   $comment = cleanXSS($_POST['text']);
   if(!get_magic_quotes_gpc()) {$comment = addslashes($comment);}
...
fix (text):
Quote
function processing() {
...
$text = $_POST['text'];
if(!get_magic_quotes_gpc()) {$text = addslashes($text);}
...
NOTE: you should run (put this line inside an empty some-name.php file, upload to your server and run it) to check whether magic_quotes_xxx is ON or OFF

my server example:
magic_quotes_gpc   On   On
magic_quotes_runtime   Off   Off
magic_quotes_sybase   Off   Off
yes!!  :D  the extra lines (in blue) solved my problem. (single quotes can be used now in Articles and in Comments)

my server:
magic_quotes_gpc:  Off     Off
Logged
E=Fb

brauck

  • Hero Member
  • *****
  • Karma: 18
  • Posts: 556
    • http://www.hbw-webdesign.nl/
Bug report
« Reply #29 on: December 03, 2006, 02:59:59 PM »

When I post an article and I give it a publish date before the date of the last article it is displayed under (before) the last article, which is right I think. However in the 'menu_articles' list it 's title is displayed as the first in the list (ergo the last posted article), which is not correct I think.
Logged
Confidence is reduced complexity.
brauck.nl for free css templates
Pages: 1 [2] 3 4