Please login or register.

Login with username, password and session length
Advanced search  

News:

You need/want an older version of sNews ? Download an older/unsupported version here.

Pages: 1 [2] 3

Author Topic: [STICKY] Bug report  (Read 19629 times)

dracko

  • Jr. Member
  • **
  • Karma: 0
  • Posts: 57
    • http://www.gritala.com
[STICKY] Bug report
« Reply #15 on: November 06, 2006, 06:59:22 AM »

Quote from: philmoz
page refreshes when saved, but still doesn't seem to update the " Display Pagination on articles" field.

Much fiddling, and recall that the previous RC had the previous field do the same, so...
in
function processing()  below  case 'save_settings':
Quote
This
$display_pagination = $_POST['display_pagination'] == 'on' ? 'True' : '';

becomes

$display_pagination = $_POST['display_pagination'] ;
now it works!!
This didnt worked for me, i also had to modify this line:
Quote
function center() {
...
if (!empty($currentPage) && ($numrows_articles > $article_limit) && s('display_pagination') == 'True') {

For this:
if (!empty($currentPage) && ($numrows_articles > $article_limit) && s('display_pagination') == 'on') {
And now it works just fine for me, it seems like the problem was a confusing 'True' and 'on' value for the pagination in the sql table, now i choose just to use de on value and avoid the True, also if you use this solution, you should ignore SerpantiN solution.
Logged

Harold

  • Full Member
  • ***
  • Karma: 0
  • Posts: 110
    • http://blog.haroldbeukers.nl/
[STICKY] Bug report
« Reply #16 on: November 08, 2006, 12:21:12 AM »

using single quotes:
by writing an article: when i use a single quote - ' like this' - ,the text won't  appear after submitting.
but if I use the dubble quotes - "like this" - then there's no problem
Logged
E=Fb

philmoz

  • High flyer
  • ULTIMATE member
  • ******
  • Karma: 161
  • Posts: 1988
    • fiddle 'n fly
[STICKY] Bug report
« Reply #17 on: November 08, 2006, 11:07:05 AM »

RSS sending [include] statements instead of the included content.

my links page is all includes.
(until I get around to making an addon specifically for a links page.)

RSS output.
Quote
includes/tuneful_inc.php includes/tech_inc.php includes/people_inc.php includes/music_websites.php includes/string_shop_inc.php
Article:
http://www.fiddlenfolk.com/links/links/
entry in the edit box, hence page content as seen in the browser.
Quote
[include]includes/tuneful_inc.php[/include]
[include]includes/tech_inc.php[/include]
[include]includes/people_inc.php[/include]
[include]includes/music_websites.php[/include]
[include]includes/string_shop_inc.php[/include]
Logged
Of all the things I have lost, it is my mind that I miss the most.

brauck

  • Hero Member
  • *****
  • Karma: 18
  • Posts: 556
    • http://www.hbw-webdesign.nl/
[STICKY] Bug report
« Reply #18 on: November 09, 2006, 12:18:17 AM »

Quote from: Harold
using single quotes:
by writing an article: when i use a single quote - ' like this' - ,the text won't  appear after submitting.
but if I use the dubble quotes - "like this" - then there's no problem
Harold you should use xhtml entities, see this
Logged
Confidence is reduced complexity.
brauck.nl for free css templates

brauck

  • Hero Member
  • *****
  • Karma: 18
  • Posts: 556
    • http://www.hbw-webdesign.nl/
[STICKY] Bug report
« Reply #19 on: November 09, 2006, 12:25:23 AM »

I don't know if this is a bug or that it was meant to be like this, but when I assign a page as home page and I check the -Display new Articles on home- box, my articles won't show on the home page.

Is this supposed to (not) happen?
Logged
Confidence is reduced complexity.
brauck.nl for free css templates

Harold

  • Full Member
  • ***
  • Karma: 0
  • Posts: 110
    • http://blog.haroldbeukers.nl/
[STICKY] Bug report
« Reply #20 on: November 09, 2006, 12:43:30 AM »

Quote from: brauck
Quote from: Harold
using single quotes:
by writing an article: when i use a single quote - ' like this' - ,the text won't  appear after submitting.
but if I use the dubble quotes - "like this" - then there's no problem
Harold you should use xhtml entities, see this
yes,thank you, that will work !

but...when a visitor wants to write a comment, then there is the same problem.
(i forgot to check that before)

update: it's a well known topic, i didn't knew as a newbie :|  search for entities on snews
and this was a solution
Logged
E=Fb

philmoz

  • High flyer
  • ULTIMATE member
  • ******
  • Karma: 161
  • Posts: 1988
    • fiddle 'n fly
[STICKY] Bug report
« Reply #21 on: November 09, 2006, 08:01:01 AM »

Quote from: brauck
I don't know if this is a bug or that it was meant to be like this, but when I assign a page as home page and I check the -Display new Articles on home- box, my articles won't show on the home page.

Is this supposed to (not) happen?
I think this is as designed.

Assigning a 'Page' to home, is in effect, making static content your default front page to the site.
Handy for an introduction to the site, what can be found etc.
Logged
Of all the things I have lost, it is my mind that I miss the most.

Elvino

  • Newbie
  • *
  • Karma: 0
  • Posts: 44
    • http://www.elvino.it/
[STICKY] Bug report
« Reply #22 on: November 12, 2006, 03:34:03 PM »

other bugs:

onKeyPress and onChange are not xhtml 1 strict standards compliance.
change with:  onkeypress  and  onchange.


on categories form
not only number for ID

example, change:
echo '

';

with:
echo '

';


on categorie admin list
not fieldset closed

to add before the last }
echo '';

Elvino

  • Newbie
  • *
  • Karma: 0
  • Posts: 44
    • http://www.elvino.it/
[STICKY] Bug report
« Reply #23 on: November 12, 2006, 03:53:13 PM »

other 5 bugs:

- on home admin page not closed the tag

if not there is the link view articles or pages etc...
- on page admin -> add category :  ID duplicated
- on page admin -> settings : ID duplicated
- validation error on page admin -> files
- duplicated language variables : $l['view'] = 'View';  line 90 and 129

Sorry for my bad english.....
 :P

Hello!

Mika

  • Hero Member
  • *****
  • Karma: 9
  • Posts: 1377
    • http://www.ni5ni6.com/
[STICKY] Bug report
« Reply #24 on: November 12, 2006, 05:36:32 PM »

you've been really busy with the bughunt - thx for your reports, elvino :)
Logged
http://www.ni5ni6.com/ - Tutorials, Mods and How-To's about sNews CMS
sNews 1.6 Developers Edition - commented sNews 1.6 version

maccrazy

  • Newbie
  • *
  • Karma: 0
  • Posts: 10
    • http://www.maccrazy.net
[STICKY] Bug report
« Reply #25 on: November 14, 2006, 09:23:32 PM »

Quote from: Luka
Thanks for the report, I'm watching this thread to correct the bugs.
Out of interest, when will RC4 or the final be out? I'm about to use sNews to re-design my site, but I will probably end up heavily modifying sNews, making future upgrades a bit more difficult, so I don't want to start today and find the sNews final is due out in a week or two and have to start again.  :P
Logged

piXelatedEmpire

  • MIA
  • ULTIMATE member
  • ******
  • Karma: 37
  • Posts: 1401
  • currently MIA
[STICKY] Bug report
« Reply #26 on: November 15, 2006, 02:35:20 AM »

I'm in the same boat maccrazy.. but just have some patience.. sNews will be ready when it's ready.
Logged
my apologies to the sNews crew, but I will be MIA for the forseeable future

philmoz

  • High flyer
  • ULTIMATE member
  • ******
  • Karma: 161
  • Posts: 1988
    • fiddle 'n fly
[STICKY] Bug report
« Reply #27 on: November 15, 2006, 11:33:59 AM »

Bug???

When logged in, should it be possible to view articles, even if they are set for future publishing?

When I press view link of future published item, I see the default no artcle (or some such -- I've altered the language var for that)
Logged
Of all the things I have lost, it is my mind that I miss the most.

Luka

  • Administrator
  • ULTIMATE member
  • ******
  • Karma: 36
  • Posts: 1716
    • http://www.snewscms.com
[STICKY] Bug report
« Reply #28 on: November 15, 2006, 01:06:10 PM »

sNews stable will be released next week, we've got most bugs fixed so I believe after I test it for a while it should be pretty stable.
Logged

maccrazy

  • Newbie
  • *
  • Karma: 0
  • Posts: 10
    • http://www.maccrazy.net
[STICKY] Bug report
« Reply #29 on: November 17, 2006, 02:55:53 AM »

Cool. Thanks for the update Luka.
Logged
Pages: 1 [2] 3