Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest sNews - sNews 1.7 - with its own forums - for discussion and user mods.

Author Topic: Default Installation does not work correctly  (Read 310 times)

phovos

  • Newbie
  • *
  • Karma: 0
  • Posts: 1
Default Installation does not work correctly
« on: October 08, 2012, 02:12:37 PM »

Hello,

I tried out sNews 1.7.1 and I have found that a default installation, following the instructions on your website, does not work correctly when creating tables in phpMyAdmin.

When using the code to populate tables, there is an error in this section:

Quote
   INSERT INTO `articles` VALUES
(1, 'Welcome to sNews 1.7', 'welcome-to-snews-17', '
If you're seeing this article, you have installed sNews 1.7 and are connected to the database.

rnrn
It is strongly suggested that you login right away, the default username and password is "test" and "test", then go to the page "settings". At the bottom of that page you'll find "Change Username and Password". Do it and make the password hard to guess.

rnrn
After doing that, feel free to delete this article & start building your site.

rnrn
If you stumble along the way, check the Troubleshooting and FAQ page.  If you're still having trouble search the sNews CMS Forum before posting your question, it may already be answered.  Still lost? We'll be there to assist you in any way we can.

rnrn
Thank you for choosing sNews.  We hope you enjoy it as much as we do.

', NOW(), 1, 1, '', '', 'YES', 'YES', 'NO', 1, '', '', 'YES', 'NO', '1', 'YES', 'NO');

The error is a syntax error, always pointing to "If you're seeing this article, you have installed sNews 1.7 and are connected to the database." This causes the code to only populate the articles table.

I managed to fix this by removing all the apostrophes (') within the text.

Our server uses PHP 5.2 and is apache.

Thank you.
Logged

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6019
  • Semantically Challenged
    • snews.ca
Re: Default Installation does not work correctly
« Reply #1 on: October 08, 2012, 04:34:47 PM »

Hi Phovos - welcome to sNews and thanks for posting the problem you were having.
I haven't had this problem when importing the snews17.sql file (provided in the SQL folder with the package) into phpMyAdmin - it always runs sucfdessfully to the end for me.

In that file, the first INSERT string for the articles table is as follows:
Code: [Select]
INSERT INTO `articles` VALUES (1, 'Welcome to sNews 1.7', 'welcome-to-snews-17', '<p>If you\'re seeing this article, you have installed <strong>sNews 1.7</strong> and it is connected to the database.</p><p>It is <strong>strongly</strong> suggested that you <a href="login/" title="Login">login</a> right away, then go to the page <em>Settings</em>. At the bottom of that page you\'ll find <em>Change Username and Password</em>. <strong>Do it</strong> and make the password hard to guess.</p><p>After doing that, feel free to delete this article and start building your site.</p>[break]<p>If you stumble along the way, check the <a href="http://snewscms.com/faq/faq/" title="Troubleshooting and FAQ">Troubleshooting and FAQ</a> page.  If you\'re still having trouble search the <a href="http://snewscms.com/forum/" title="sNews CMS Forum">sNews CMS Forum</a> before posting your question, it may already be answered.  Still lost? We\'ll be there to assist you in any way we can.</p><p>Thank you for choosing sNews.  We hope you enjoy it as much as we do.</p>', NOW(), 1, 1, '', '', 'YES', 'YES', 'NO', 1, '', '', 'YES', 'NO', '1', 'YES', 'NO');

... and in it, you will notice that the apostrophes are preceded by a backward slash, which should eliminate the problem you described.

Have you tried populating a database using the snews17.sql file?
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU