Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2]

Author Topic: Login/404 error bug  (Read 985 times)

Fred K

  • Still trying to learn stuff
  • ULTIMATE member
  • ******
  • Karma: 130
  • Posts: 2728
    • Personal
Re: Login/404 error bug
« Reply #15 on: August 31, 2012, 02:23:03 AM »

Jason, it seems to do as advertised. Only done a quick local test so far so no standard notification-setting usage has been tested yet (like contact form) so obviously it's hard to tell if adverse effects, but for the login process it's great.
I know it's not much but, thanks a lot for the effort. If this fix works across the board of notifications, even without having to change any "factory" settings, then this bug could finally be crossed of the board, I think. Then again, it's me talking, so... :D 8)
At least 1 karma added.
Logged

nukpana

  • Hero Member
  • *****
  • Karma: 71
  • Posts: 663
Re: Login/404 error bug
« Reply #16 on: August 31, 2012, 10:05:54 PM »

Thanks Fred. I added a minor update to my previous post.  The whole thing feels very hacky and as you speculated (even prior to the fixes the past few days), and needs to be rewritten/rethought out on how to work it.  For now, I think this should work for the current version.  Again, more testing is needed before we can call this solved.
Logged

Fred K

  • Still trying to learn stuff
  • ULTIMATE member
  • ******
  • Karma: 130
  • Posts: 2728
    • Personal
Re: Login/404 error bug
« Reply #17 on: September 01, 2012, 06:15:29 PM »

Yeah, rewriting's the best option - if we get there. I just noticed that if I enter a wrong username or password then the error message becomes "you're not allowed to do that until logged in" rather than what it's supposed to be, but that's with the original fix (haven't included your minor update yet). Of course the current fix makes the process work so having an absolutely correct error message when something goes wrong rahter than a slightly wonky error message seems very minor. Like a hiccup.
Logged

nukpana

  • Hero Member
  • *****
  • Karma: 71
  • Posts: 663
Re: Login/404 error bug
« Reply #18 on: September 01, 2012, 09:20:35 PM »

You still need to apply this:
http://snewscms.com/forum/index.php/topic,10499.msg69452.html#msg69452

Then:
http://snewscms.com/forum/index.php/topic,10499.msg69452.html#msg69452

it sounds like it is still directing to administration() without the check, so the initial part still needs to be applied.

For a rewrite, yes on a new version, but for the stable version - to fix a bug, maybe this is "ok" for now. 
« Last Edit: September 01, 2012, 09:26:45 PM by nukpana »
Logged

Fred K

  • Still trying to learn stuff
  • ULTIMATE member
  • ******
  • Karma: 130
  • Posts: 2728
    • Personal
Re: Login/404 error bug
« Reply #19 on: September 02, 2012, 01:24:49 AM »

My mistake really - without noticing it I had put in two cases for Loginform in center... heh * ;)
In other words, the fix is good as a stop-gap measure. Amazing what you can do with a little duct tape and Wrigley's Spearmint... (when instructions are followed, erm, correctly).

* = me and my thick head... sorr-y
Logged
Pages: 1 [2]