Please login or register.

Login with username, password and session length
Advanced search  

News:

Latest sNews - sNews 1.7 - with its own forums - for discussion and user mods.

Author Topic: Blankspace Theme Package 1.0 ready  (Read 490 times)

blankspace

  • Newbie
  • *
  • Karma: 3
  • Posts: 22
Blankspace Theme Package 1.0 ready
« on: July 22, 2012, 05:37:30 PM »

Hello!
Presenting an original theme package for sNews 1.7.1 I call Blankspace. You can see it working here: http://www.grand-central.eu/blankspace/

Theme is built with responsive web design, it has three sizes for different devices: max 480px wide for smartphones, max 768px for tablets in vertical orientation and more than 768px wide for tablets in horizontal orientation and other screens wider than 768px. Theme is built with HTML5, CSS3 and includes jQuery and Modernizr Javascript libraries. Also includes sNews 1.7.1 modified version. You can read about theme and changes in sNews on the site (link above).

Sorry, I can't show screengrabs because my site domain is not allow to hotlink images. If you resize your browser window you can see how it changes on break points. (Because CSS3 is used a lot, a recent version of operating system and browser is needed. Windows older than 7, iOS older than 4 and Mac OS older than 10.5 probably no good.)

To download, visit http://www.grand-central.eu/blankspace/ and click link in sidebar where says "Download".

And it is free! :-)
« Last Edit: July 22, 2012, 05:50:15 PM by blankspace »
Logged
All your internets are belong to us

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6019
  • Semantically Challenged
    • snews.ca
Re: Blankspace Theme Package 1.0 ready
« Reply #1 on: July 22, 2012, 09:44:18 PM »

Thanks for sharing your new template project blankspace!  8)

Have a look at the W3C CSS Markup Validation Service results for your home page. It will help you tune up your CSS declarations to make your CSS pass the validation test without errors reported. You can also do the same for any other page generated in your template by pasting the page URLs in the validation address field.  :)
« Last Edit: July 23, 2012, 03:20:14 AM by Keyrocks »
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU

blankspace

  • Newbie
  • *
  • Karma: 3
  • Posts: 22
Re: Blankspace Theme Package 1.0 ready
« Reply #2 on: July 23, 2012, 12:49:56 AM »

Hello mr Keyrocks! Thank you for looking and for pointing to error. To be clear, all errors except one are not in the package, they are from CC license code which is only on the site and not a worry for me. But however I noticed I make a silly error when changing the jump_to mod which cause the other error. That is in the package, so thank you for reporting so I find it. The error is now fixed and the corrected theme package uploaded to the site (same name, same link).

Minor thing, the link you gave is for the W3C HTML validator, not CSS validator. The W3C CSS validator reports many errors only for items with vendor prefix (like -webkit-bla-bla or -moz-bla-bla), but this does not make them wrong or bad, only the validator does not recognize them. Is so bad I have stopped checking with it.

Anyway, thank you, the real error was fixed.
Also I can say thank you to mr Fred K who help me a lot with theme and articles on site (my English as you see not so good, ha-ha). Also he point me to sNews in the first place, so thanks mr Freddy! :-) And thank you to mr nukpana and mr infomix for help with some problems in this theme, they mean a lot.

Ciao,
/Pax
Logged
All your internets are belong to us

Keyrocks

  • Doug
  • ULTIMATE member
  • ******
  • Karma: 449
  • Posts: 6019
  • Semantically Challenged
    • snews.ca
Re: Blankspace Theme Package 1.0 ready
« Reply #3 on: July 23, 2012, 03:27:27 AM »

Minor thing, the link you gave is for the W3C HTML validator, not CSS validator.

My apology... I've fixed the link  8)

The W3C CSS validator reports many errors only for items with vendor prefix (like -webkit-bla-bla or -moz-bla-bla), but this does not make them wrong or bad, only the validator does not recognize them. Is so bad I have stopped checking with it.

I did not suggest they were wrong or bad. Of course you can leave them as they are. These warnings always come up in the Error Console plug-in for F-Fox. I've shied away from using those declarations at all now only to eliminate the warnings they continue to throw. I've found that there isn't much difference in the overal presentation without them. But, of course (as Fred K would say), this is only my personal point of view and not to be construed as having any relationship to a 'Holy Grail' of CSS usage.  ;D

Your template is a fine contribution to the sNews project as it is.  :)
« Last Edit: July 23, 2012, 03:29:02 AM by Keyrocks »
Logged
Do it now... later may not come.
-------------------------------------------------------------------------------------------------
sNews 1.6 MESU | sNews 1.6 MEMU